Confilict on versions between Nvidia driver cuda-toolkit and tensorrt

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
• DeepStream Version
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
AWS instance g4dn.xlarge
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
Download the
Donload the deepstream-5.1_5.1.0-1_amd64.deb
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

I tried to install the deepstream manually on dgpu according to the quick start.
After installing the Nvidia driver, and start to run the asked Cuda toolkit version I found out that the Nvidia version is not matched with what is offering the Cuda installer on Cuda version 1.1

I removed the previous Nvidia driver and accepting the default driver I tried to install the tensorRT
7.2 I downloaded the corresponding file nv-tensorrt-repo-ubuntu1804-cuda11.0-trt7.2.0.14-rc-20200901_1-1_amd64.deb and tried to install that based on the guide but there is a difference between ga and rc
Accodring to what manual is suggesting the file should be ga but the repositoty file is rc :
os=“ubuntu1x04” tag=“cudax.x-trt7.x.x.x-ga-yyyymmdd” sudo dpkg -i nv-tensorrt-repo-${os}-${tag}_1-1_amd64.deb sudo apt-key add /var/nv-tensorrt-repo-${tag}/ sudo apt-get update sudo apt-get install tensorrt
After trying to do the installation I got the follwoing error
The following packages have unmet dependencies:

tensorrt : Depends: libnvinfer-dev (= 7.2.0-1+cuda11.0) but 8.0.3-1+cuda11.3 is to be installed
Depends: libnvinfer-plugin-dev (= 7.2.0-1+cuda11.0) but 8.0.3-1+cuda11.3 is to be installed
Depends: libnvparsers-dev (= 7.2.0-1+cuda11.0) but 8.0.3-1+cuda11.3 is to be installed
Depends: libnvonnxparsers-dev (= 7.2.0-1+cuda11.0) but 8.0.3-1+cuda11.3 is to be installed
Depends: libnvinfer-samples (= 7.2.0-1+cuda11.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Now I do appreciate it if you can provide the proper link and instruction to implement the dgpu solution for deepstream5.1 and a table of the version compatibility.

dGPU setup:
and information about platform and operating system compatibility

1 Like

So you mean that I should install everything on Redhat-rhel and the things are not working on Linux-Ubuntu?
Because AWS instances are not OS-dependent and the instance that I am using can run both Ubuntu and redhat.


Yes. you should fix the errors. another way is you can use docker which have the software installed already.