ConnectX4 and SRIOV : supporting VL ?

Hello,

On my testing environment, I would like to use ConnectX4 HCA with SRIOV enabled. I’m having trouble using multiple VL.

I’m running CentOS7.1 and MLNX_OFED_LINUX-3.1-1.0.3 (OFED-3.1-1.0.3)

Here are the details of my card :

HCA : ibv_devinfo

hca_id: mlx5_0

transport: InfiniBand (0)

fw_ver: 12.12.1100

node_guid: e41d:2d03:00f2:9fb4

sys_image_guid: e41d:2d03:00f2:9fb4

vendor_id: 0x02c9

vendor_part_id: 4115

hw_ver: 0x0

board_id: MT_2180110032

phys_port_cnt: 1

port: 1

state: PORT_ACTIVE (4)

max_mtu: 4096 (5)

active_mtu: 4096 (5)

sm_lid: 1

port_lid: 8

port_lmc: 0x00

link_layer: InfiniBand

My issue is that the number of VL activated on the network is only 1 :

smpquery PI 8 1 | grep .VL

VLCap:…VL0

OperVLs:…VL0

How can I use the maximum number of VL (8) on a connectX4 HCA with SRIOV enabled ?

Thanks !

Jerome

Hi Jerome David,

Sorry for the late reply.

It seems at this point only 1VL is supported with SR- IOV configured and enabled.

Thanks,

Vishal

Hi Vishal,

Sorry I was out of office since your answer.

Thank you for the clear answer.

Do you know if there is any plan to get VL support with SRIOV on connectX4 ?

We actually use that feature with connectX2 and connectX3. So for us the lack of this feature is a regrassion.

Do you have any info on How to do QoS when SRIOV is enabled ? Is see at leat 2 needs here :

  • Garantee a minimum BW per VM on an Hypervisor using SRIOV (Maybe there is a feature in SRIOV for that ?)

  • Garantee a minimum BW per SL per Hypervisor (My opinion is that VL are mandatory).

Thanks,

Jérôme