Could not get EGL display connection

• Hardware Platform (Jetson / GPU) : Jetson nano
• DeepStream Version : Deepstream L4T - 6.1.1-samples
• JetPack Version (valid for Jetson only) Jetpack 4.6.1
• TensorRT Version - 8.2.1

I connecting to my jetson nano using ssh user-name@ipadrress. After connected I launched a container based on the image of deepstream-6.1.1-samples which I added the python bindings. Then I launch my container using the following: sudo docker run -it --rm --net=host --runtime nvidia -e DISPLAY=$DISPLAY -w /opt/nvidia/deepstream/deepstream -v /tmp/.X11-unix/:/tmp/.X11-unix deepstream-python:v2

I tried to run any example, including deepstream-test1-rtsp-out, which not include render instead a server, but I always get the same error in every example:

(Argus) Error FileOperationFailed: Connecting to nvargus-daemon failed: No such file or directory (in src/rpc/socket/client/SocketClientDispatch.cpp, function openSocketConnection(), line 205)
(Argus) Error FileOperationFailed: Cannot create camera provider (in src/rpc/socket/client/SocketClientDispatch.cpp, function createCameraProvider(), line 106)

Is there a monitor connected to your Jetson? Besides, the deepstream 6.1.1 needs Jetpack 5.0.2. Please follow the link below to configure your environment:

Thanks. So I should be working with deepstream-l4t:6.0.1instead and just rtsp output

But not, there is no monitor connected

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.