Couldn't detect external monitor in ubuntu 18.04.5 with NVIDIA driver 455.38

Hi,all. It’s my 1st time of using this platform. Hope my format is correct.

I can’t even detect the external monitor when inside UBUNTU 18.04.5 but able to connect to the external monitor in WINDOWS 10.

My laptop is Acer Nitro 5 [AN515-44-R1AZ, AMD Ryzen 7 4800H + NVIDIA GeForce GTX 16500]

Current NVIDIA driver in my laptop is NVIDIA v455

Ways I have tried:
Secure boot is disable.

  1. I have tried to install [NVIDIA driver meta package from nvidia-driveri455(proprietary,tested] from the Software and Updates.
  2. Tried to install the package[nvidia-driver 450] which downloaded from (

Hope to hear from you guys soon.

After following this tutorial, I managed to connect to the external monitor but my laptop’s monitor hang at login screen.

Tutorial link: []

nvidia-bug-report.log.gz (286.4 KB)

Any support from nvidia ?

I have the same problem with the same CPU and a RTX2060. For me the Fix in:
nvidia-xconfig doesnt do what i want it to, nor does nvidia-settings
worked in Ubuntu 20.04 but not in 18.04 on the same machine. If it is not important for you to use 18.04 you could try Ubuntu 20.04.
I have to use 18.04 so I am still hoping for a solution someday

Important to use 18.04 but looks like quite less ppl view my post…

Hi yoyoguy,

PRIME is required to use both monitors at the same time. See for more information. For a basic PRIME config, try running ‘nvidia-xconfig --prime’.

Please try it and if issue still persists, please share new bug report…

1 Like

Hi, thank you for your reply. I will try it out later.

The provided readme is for intel isn’t it?

Section "Device"
    Identifier "intel"
    Driver "modesetting"

Section "Screen"
    Identifier "intel"
    Device "intel"

How to do it for our AMD 4800 CPU?

The setting for PRIME looks quite different for my case?
Replacing others and not going to change the input device right?
xorg.conf.txt (1.4 KB)

I guess the problem is that the kernel 5.4 that comes with 18.04 is too old to support the AMD gpu. If you really can’t upgrade to 20.04, you’ll have to install a more recent kernel:

1 Like

Thank you for your answer. Sadly I already updated to Kernel 5.8.0-16 knowing the 5.4 is too old.
On Ubuntu 20.04 a kernel update combined with your fix from nvidia-xconfig doesnt do what i want it to, nor does nvidia-settings works like a charm. But sadly not on Ubuntu 18.04

You are probably right, the problem is the amdgpu and not the nvidia one because with “primaryGPU” “Yes” I got the external displays running. But the internal stays off.

On 18.04, you also need to download the AMD firmware files, see this parallel thread:

1 Like

I did not knew that. Thank you very much for providing it. Will try out asap.

Edit: It worked! Thank you generix! I updated the firmware for iwlwifi too and got my wifi problems fixed as well. There was no single file for renoir before.
I will summarize my steps shortly for who ever is reading this.

  1. Ubuntu18.04
  2. Upgrade Kernel to 5.8.0
  3. Cloned the firmware repo and copied all files for renoir- to lib/firmware/amdgpu (Do not forget to macke a backup)
  4. Installed nvidia-driver 450.80.02
  5. Used generix fix described in this post (Please read carefully there are 2 methods described in given post. Do not mix them.)

Point 3. is important for Ubuntu 18.04. The same way worked for Ubuntu20.04 but 3. is optional

1 Like

After I update the Kernel to 5.8.0 and reboot, my ubuntu stuck at loading screen with >>> snd_soc_register_card failed (-517) <<<. Do you meet this problem too?

Then you likely didn’t/incorrectly downloaded the firmware files. Please check
ls -l /lib/firmware/amdgpu/renoir*
and compare the filesizes with the git ones.
Another reason might be that you created an xorg.conf. Please delete it in that case.

1 Like

It worked! Thank you generix!
I will summarize my steps throughout the whole process.
My laptop specs:

  1. Ryzen 7 4800h
  2. Nvidia GTX 1650
  3. Ubuntu 18.04

The steps:

  1. Install Nvidia Driver 450.80.02
    $ sudo add-apt-repository ppa:graphics-drivers/ppa
    $ sudo apt update
    $ ubuntu-drivers devices
    $ sudo apt install nvidia-450
    Please look online for more information how to install the Nvidia Driver and use nvidia-smi to check whether the nvidia driver is installed or not.

  2. sudo add-apt-repository ppa:cappelikan/ppa sudo apt update sudo apt install mainline
    To install the Linux 5.9.16-050916-generic or any suitable version.

  3. Download all firmware files that begin with “renoir” from
    To download click plain at last column.
    Put them into /lib/firmware/amdgpu.

  4. sudo update-initramfs -u
    To rebuild the initrd.

  5. Delete /etc/X11/xorg.conf.
    Modify /usr/share/X11/xorg.conf.d/10-amdgpu.conf
    Replace >>> Driver “amdgpu” <<< with >>> Driver “modesetting” <<<.
    Then, add >>> Option “PrimaryGPU” “Yes” <<< inside OutputClass of /usr/share/X11/xorg.conf.d/10-nvidia.conf.

  6. Create two files optimus.desktop containing:

[Desktop Entry]
Exec=sh -c “xrandr --setprovideroutputsource modesetting NVIDIA-0; xrandr --auto”

and PASTE in:
Final, reboot the system.


1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.