GeForce GTX 1650 Ti and Linux Mint 19.3

Thank you for your responsiveness! Here is the bug reportnvidia-bug-report.log (3.4 MB)

You need to use 430.xx or 440.xx driver instead of the 390.xx legacy driver.

May 25 00:00:24 PM kernel: [ 4.951258] NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:1f95)
May 25 00:00:24 PM kernel: [ 4.951258] NVRM: installed in this system is not supported by the
May 25 00:00:24 PM kernel: [ 4.951258] NVRM: NVIDIA 390.132 driver release.
May 25 00:00:24 PM kernel: [ 4.951258] NVRM: Please see ‘Appendix A - Supported NVIDIA GPU Products’
May 25 00:00:24 PM kernel: [ 4.951258] NVRM: in this release’s README, available on the operating system
May 25 00:00:24 PM kernel: [ 4.951258] NVRM: specific graphics driver download page at
May 25 00:00:24 PM kernel: [ 4.951486] NVRM: The NVIDIA probe routine failed for 1 device(s).
May 25 00:00:24 PM kernel: [ 4.951487] NVRM: None of the NVIDIA graphics adapters were initialized!

Additionally, you’ll also need a newer kernel to make your AMD graphics work, upgrade to latest HWE:

sudo apt-get install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04

afterwards, some tweaks have to be done to make the AMD/Nvidia combo work:

Follow your intructions : 440 driver, upgrade to latest HWE, and follow manipulations from
No return with “ubuntu-drivers devices”, no Geforce 1650ti in “hardinfo”.
Here is the new bug report …nvidia-bug-report.log (1.4 MB)
Thanks in advance

Ah ; also, I am on Ubuntu 20.04 now (so I’ve add “nouveau.modeset=0” in grub just after “quiet splash”)…No difference with Mint 19.3.

The nvidia gpu is installed fine, driver works. The problem is with your AMD gpu which is needed to work but is brand new (Ryzen 7 4800H)
Please install a 5.6 kernel:
You’ll need to download and install
kernel headers
kernel image specific headers
kernel image

1 Like

Ok kernel 5.6 is installed, 5.4 is purged.
No 1650ti in “lspci -vnn | grep VGA” or in “hardinfo”… Is it normal ?
New report nvidia-bug-report.log (1.6 MB)


The amd gpu is working now but you put
Option “PrimaryGPU” “Yes”
into the wrong file. Please fix.

lspci displays the nvidia gpu well:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:1f95] (rev a1)

if you want a proper name, update the pciid db:

sudo update-pciids

Ok nice. “About” in “settings” of ubuntu or “Hardinfo” give me AMD RENOIR for OpenGL Renderer. Why not my nvidia ? And can you explain me why there are no additionnals pilotes and why “ubuntu-drivers devices” return nothing ?

thanks again

Did you put the primary option into the correct file? did you also create the two .desktop files? If so, please attach a new nvidia-bug-report.log.
ubuntu-drivers devices probably doesn’t yet know your gpu.

Yes & Yes… Report :nvidia-bug-report.log (1.6 MB)

Looks fine, nvidia gpu is primary, all processes running on it. (nvidia-smi --query)
So if anything is displaying something different, it’s wrong.
glxinfo |grep vendor
should report “Nvidia”

You should disable the nvidia persistenced
sudo systemctl disable nvidia-persistenced
this should make it possible to switch back to amd only using
sudo prime-select intel

“glxinfo |grep vendor” report :

server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation

Just surprised that “ubuntu-drivers devices” doesn’t return anything…and that no additional drivers be offered in “drivers”…

Maybe the package
needs to be updated, otherwise create a bug report at Ubuntu’s bug-tracker.

Ok Generix thank you for everything. You solved my problem!

Hi i think my issue is really similar to Mozzarella’s. Im a complete Linux newbie with Ubuntu 20.04 LTS and i have almost the same laptop than him. Main difference is mine has Ryzen 5 R5-3550H and GTX 1650. My issue is that my laptop is unable to detect my second monitor with HDMI cable. i followed this guide for installing my driver:
but when i tried to run this command: nvidia-settings
i got this error: (nvidia-settings:17078): GLib-GObject-CRITICAL **: 15:38:01.487: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** Message: 15:38:01.490: PRIME: No offloading required. Abort
** Message: 15:38:01.490: PRIME: is it supported? no

I also tried switching between gdm3 and lightdm display managers and no good. I’ll append my bug report for you, thanks for taking the time!
nvidia-bug-report.log (1.0 MB)

Please see this:

Thank you so much for your quick response, regarding the link you posted, first there is no file ‘xorg.conf’

pollo@guillermoPC:/etc/X11$ ls
app-defaults rgb.txt Xreset.d Xsession.options
cursors xinit Xresources xsm
default-display-manager xkb Xsession XvMCConfig
fonts Xreset Xsession.d Xwrapper.config

Also there is no share folder inside usr directory:

pollo@guillermoPC:~$ ls
Desktop Downloads nvidia-bug-report.log.gz Public Videos
Documents Music Pictures Templates

And just to see if i understood you correctly,
I quote “Downside of this is that no external monitors connected to the nvidia gpu will work.”
This means that there is nothing i can do to connect my second monitor to my laptop?
Again thank you for taking the time to help out a newbie.

If there’s no xorg.conf, you don’t need to delete it.

The post describes two different setups, PRIME output with support for external monitors and PRIME offload aka render offload without it.

Not the “user” directory which is in /home on linux but /usr which is short for “unix special resources”, it’s a system directory. To modify the files, e.g. open a terminal and run
sudo -i
to get a root shell, then
nano -w /usr/share/X11/xorg.conf.d/10-amdgpu.conf
modify, press ctrl+o ctrl+x to save and exit the first file
nano -w /usr/share/X11/xorg.conf.d/10-nvidia.conf
ctrl+o ctrl+x to save and exit the second file

1 Like

This guide solved my ASUS GA401II - ubuntu20 GTX 1650i + AMD 4800HS issue !! thanks

one reminder is the secured boot need to be disabled on bios

lspci -vnn | grep VGA
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation TU116M [GeForce GTX 1650 Ti Mobile] [10de:2192] (rev a1) (prog-if 00 [VGA controller])
04:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Renoir [1002:1636] (rev c6) (prog-if 00 [VGA controller])