Problem with dedicated GTX 1660TI gpu in Asus FX505D

I have tried to install Nvidia proprietary driver from the official website and unoficial repisitory, but I got black screen, when OS starts to boot. Also in Driver manager I don’t see option for Nvidia dedicated gpu. On other computers with different Nvidia gpus I don’t have that problem, it always shows the driver. Is this wide spread issue? Or maybe official gpu drivers are not yet avaliable? How do I get working dedicated GPU?

Integrated AMD gpu works without any problems

I am using Kubuntu 19.04 64bit

Edit: I have added the resulting file, however it is not .gz file, it is .log file. I installed the drivers then ran the nvidia-bug-report.sh (without restarting). After restarting I get black screen instantly, even the magical button combinations to launch terminal doesn’t work, BUT OS kinda boots. When using FN + function keys I can change brigtness and sound (I get sound noise from OS)
nvidia-bug-report.log (203 KB)

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

This is a hybrid graphics notebook, so you can’t really use the .run installer driver. Please uninstall it using the --uninstall option.
Afterwards,

Please make sure that the package nvidia-prime is installed
sudo apt install nvidia-prime
Remove any /etc/X11/xorg.conf you created.
sudo rm /etc/X11/xorg.conf
Then you’ll have to make some config changes:

  • modify /usr/share/X11/xorg.conf.d/10-amdgpu.conf
    replacing only
Driver "amdgpu"

with

Driver "modesetting"
  • Please add
Option "PrimaryGPU" "Yes"

inside the OutputClass of /usr/share/X11/xorg.conf.d/10-nvidia.conf
Afterwards, run
sudo prime-select nvidia
remove any stray blacklist files
sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf
then reboot.

While now I can get dedicated gpu working, when will this be avaliable in official driver app? Currently this seem like a big hack. Also, what is happening now with AMD gpu? Can I quicly switch to AMD or Nvidia to save power or get performance? Btw I used 430 and not 435 because it is not acaliable for Kubuntu 19.04, only for 18.04

Also, my font got reduced in size, luckally in KDE system setting under font I was able to set it back to normal size.

Thanks

To switch back to amd, run
sudo prime-select intel
and reboot.
To have this auto set up, it has to be integrated at distro-level, i.e. in Ubuntu’s nvidia-prime package. Someone has to create a feature request on that, though.

Thank you very much. I had the same problem, now solved.

Thank you very much. I had also the same problem, now also solved :)

It also works for Ubuntu 19.10