ASUS TUF A15 GTX 1660 ti on Ubuntu 18.04 fresh install, black screen when booting + unknown display device

I have an ASUS TUF A15 laptop with NVidia GTX 1660 ti graphics card. I installed Ubuntu 18.04 and tried everything here and here except manual install with .run files. I selected all options in Software & Updates one by one and rebooted. However, I could not get the Nvidia drivers up in Ubuntu, it always got stuck at boot (black screen). Also, it does not recognize an external screen, the default screen is “unknown display”.

I reinstalled Ubuntu freshly and went for the recommended approach in these forums: Just selected the recommended option in Software & Updates as follows:

I rebooted and voila, it was able to boot! I could even nvidia-smi with proper output and could see the nvidia-settings properly (previously it would show an empty window). However, Ubuntu > About still showed llvmpipe as the graphics device:
image

External and default screens were still not recognized. To solve this, I tried to reselect nvidia as follows:

sudo prime-select intel
sudo prime-select nvidia
reboot

At this point I was setback to the black screen at boot state! I tried both nomodeset or nouveau.modeset=0, but didn’t work. Now I am stuck again… Debug sh output is included. Please help, it already cost 1.5 days to me.

nvidia-bug-report.log.gz (106.8 KB)

Meanwhile, I followed some suggestions on this forum topic:

  • delete /etc/X11/xorg.conf (it didn’t exist for me)
  • make sure nvidia-prime is installed (sudo apt install --reinstall nvidia-prime)
  • switch to nvidia (sudo prime-select nvidia)
  • remove stray blacklist files (sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf)
  • update the initrd (sudo update-initramfs -u)
  • reboot

plus changed options nvidia-drm modeset=1 to options nvidia-drm modeset=0 in /lib/modprobe.d/nvidia-kms.conf.

Also added the kernel parameters acpi_osi=! acpi_osi=Windows\ 2009

The system did not stick in the black screen at boot and nvidia-smi produces a sensible output:

+-----------------------------------------------------------------------------+
| NVIDIA-SMI 440.95.01    Driver Version: 440.95.01    CUDA Version: 10.2     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 166...  Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   52C    P0     7W /  N/A |      0MiB /  5944MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|  No running processes found                                                 |
+-----------------------------------------------------------------------------+

However, nvidia-settings shows an empty window and the system still does not recognize my main display device.

Here I generated a new bug report: nvidia-bug-report.log.gz (343.4 KB)

Meanwhile, I tried other suggestions from here and there in the forums, similar to my issues:

  • WaylandEnable=false in /etc/gdm3/custom.conf.
  • Install lightdm instead of gdm3.
  • Set AMD-specific variables and create optimus.desktop entries as suggested here.

None worked so far. The last one permits booting (I can hear Ubuntu tune), but it shows black screen. In the other options I am stuck at the boot “PPM init failed” as before.

I am still in need of help.

Pretty much the same boat. I have an Asus TUF706 which I think is the same as A17. Same Nvidia GPU and same Ryzen 7 and on the same PCI addresses. However, I’m using Mint 20 and kernel 5.8 from Ubuntu.

I actually had nvidia-smi giving a good output, but it said Off as well, nvidia-settings wasn’t blank, and prime select was on nvidia. But, even with that, I’m pretty sure it was still using the amdgpu. I’ve tried nearly all the same steps and now none of that is working and I have to have prime set to intel to not get a blank screen.

Maybe it actually was working and I need to undo the couple of changes I made today.

It seemed like it doesn’t detect any displays. My modeset was already at 0. Attached is my bug report from the last attempt.

nvidia-bug-report.log.gz (242.1 KB)

Ok, I got it back “working” by undoing the two changes I had made.
for /usr/share/X11/xorg.conf.d/10-amdgpu.conf
setting Driver back to “amdgpu”, earlier I had changed it to “modesetting”
and
10-nvidia.conf, removing
Option “PrimaryGPU” “Yes”.

Then set prime-select back to nvidia.

New nvidia bug report.
nvidia-bug-report.log.gz (247.5 KB)
Here is my current nvidia-smi output:
Screenshot from 2020-10-01 17-57-24

So is it actually using the nvidia GPU now because it still says “Off” and that’s what’s confusing me.
I think it actually is because now Factorio has the sprite resolution to High. Before it wouldn’t let me set it to that because it wanted at least 3GB of VRAM and the amdgpu doesn’t have that.

Hi DotimusPrime, thank you for sharing your experience. I tried those things earlier but did not solve it for me.

I am afraid, this forum is abandoned. I wish nvidia supported their product properly… It has been two weeks since I bought this PC and I still can’t use its graphics card! It doesn’t even let me do very basic things like connecting an external screen -_-

Hin

Allways using the Nvidia GPU is note the best solution.

First off all you need a 5.8 kernel : https://doc.ubuntu-fr.org/asus-a17-tuf766iu#ajout_du_noyau_58_recommande

Install the latest nvidia driver : https://doc.ubuntu-fr.org/asus-a17-tuf766iu#installation_des_pilotes_nvidia

Then you can :

I wrote this pages in french.