nVidia graphics not recognized on ASUS A15 TUF506IU

I have an ASUS TufBook A15 TUF506IU - Ryzen 4800H with Vega integrated graphics and an nVidia GTX 1660ti / 6Gb. Im currently running Mint 20 (same packages as Ubuntu 20.04), and I’m using mainline kernel 5.9.8. Im currently using driver version 455.38.

The issue Im having is that even after installing the nvidia driver, and trying “sudo prime-select nvidia”, my machine is not using the nvidia driver. If I run “glxinfo | grep OpenGL”, I can see clearly that it’s using Renoir (AMD) integrated graphics. Also, if I run nvidia-smi, the GPU is clearly indicated as being “Off”, and there is no GPU utilization at all.

I’d appreciate any help at all to get this working. I normally don’t have so many problems getting nVidia graphics to work, which is why I usually recommend them to my friends that use Linux (yes, believe it or not, there are more than two of us!).

Thanks in advance,

jonbitzen

Update:

  • there are quite a few other posters with issues similar to mine, which involve hybrid graphics
  • I disabled secure boot and cleared keys, still no joy
  • I ran nvidia-bug-report.sh, and I have attached the output gz file

nvidia-bug-report.log.gz (258.8 KB)

Your system is in a “render offload” configuration where the desktop and applications are rendered on the AMD GPU by default. The NVIDIA GPU will be used for specific applications if you launch them with the appropriate environment variables set to offload rendering to the NVIDIA GPU.

Is there a way to cause the system to use the nVidia driver for the entire desktop session? I’d thought, that “sudo prime-select nvidia” would cause it to do that. Previously on my intel/nvidia laptop I had a widget in the system tray that would do that which I no longer see, and I’d assumed prime-select was the commandline way to do the same thing.

In the end I’d like to be able to connect my external monitors to the USB-C and HDMI ports and use the laptop for development when I’m at my desk, and my hope is the external connections will function properly once I can get the nVidia graphics chip to be used for the desktop session.

Thanks,

jonbitzen