CPU's utilization

Is there any advice on how to get 0% loaded CPU’s utilized when cpu0 is 100% loaded by other 0%loaded in routine GUI use of Ubuntu?
Resolved: https://devtalk.nvidia.com/default/topic/1000345/jetson-tx2/two-cores-disabled-/
& http://www.jetsonhacks.com/2017/03/25/nvpmodel-nvidia-jetson-tx2-development-kit/

Hardware drivers will always run on CPU0, all other software could run on something different. Threading, CPU affinity, and scheduling are all long and old topics. Assuming you have already set the clocks to max (at least for testing to be sure other cores are not disabled), which software do you want on other cores, and how is it launched?

I was just building TensorFlow. It used to eat 100% of every cpu, finally,
I think I am interested in Deep Neural Networks utilizing more than one cpu. However, just testing was and still is my main goal.
I added few “1” : echo 1 > /sys/devices/system/cpu/cpu1/online to enable cpus
I think now all cpus are enabled:

sudo nvpmodel -q –verbose
NV Power Mode: MAXP_CORE_ALL
2
./jetson_clocks.sh --show
SOC family:tegra186  Machine:quill
Online CPUs: 0-5
CPU Cluster Switching: Disabled
cpu0: Gonvernor=schedutil MinFreq=345600 MaxFreq=1400000 CurrentFreq=1267200
cpu1: Gonvernor=schedutil MinFreq=345600 MaxFreq=1400000 CurrentFreq=345600
cpu2: Gonvernor=schedutil MinFreq=345600 MaxFreq=1400000 CurrentFreq=345600
cpu3: Gonvernor=schedutil MinFreq=345600 MaxFreq=1400000 CurrentFreq=806400
cpu4: Gonvernor=schedutil MinFreq=345600 MaxFreq=1400000 CurrentFreq=960000
cpu5: Gonvernor=schedutil MinFreq=345600 MaxFreq=1400000 CurrentFreq=1267200
GPU MinFreq=140250000 MaxFreq=1120000000 CurrentFreq=140250000
EMC MinFreq=40800000 MaxFreq=1866000000 CurrentFreq=665600000 FreqOverride=0
Fan: speed=0
./jetson_clocks.sh --show
SOC family:tegra186  Machine:quill
Online CPUs: 0-5
CPU Cluster Switching: Disabled
cpu0: Gonvernor=schedutil MinFreq=345600 MaxFreq=1400000 CurrentFreq=1267200
cpu1: Gonvernor=schedutil MinFreq=345600 MaxFreq=1400000 CurrentFreq=345600
cpu2: Gonvernor=schedutil MinFreq=345600 MaxFreq=1400000 CurrentFreq=345600
cpu3: Gonvernor=schedutil MinFreq=345600 MaxFreq=1400000 CurrentFreq=806400
cpu4: Gonvernor=schedutil MinFreq=345600 MaxFreq=1400000 CurrentFreq=960000
cpu5: Gonvernor=schedutil MinFreq=345600 MaxFreq=1400000 CurrentFreq=1267200
GPU MinFreq=140250000 MaxFreq=1120000000 CurrentFreq=140250000
EMC MinFreq=40800000 MaxFreq=1866000000 CurrentFreq=665600000 FreqOverride=0
Fan: speed=0

Will that settings be optimal for use of the board as a stationary desktop ?
I think the less is the insensitivity of usage of cpus and gpus - the longer will be the lifetime of the device which is said to be approximately 3-5 years

Thank you for asking!

If using the Jetson as a desktop I’d just set to max and leave it that way. Running on a battery isn’t an issue, and you’re not filling a data center, so that’s maybe an extra 7.5 watts…hardly worth mentioning in the desktop PC world.

I do not know what the life expectancy changes will be if always on max clock 24x7. There are still parts of the system in place which will throttle back if temperature goes up…someone from NVIDIA might want to comment on life expectancy versus clock settings. Unless you are running in a harsh environment I suspect normal throttling combined with a default of max clocks won’t be much of an issue.

if I am trying to run chromium-browser on a particular core:

taskset -c 4 chromium-browser

why the core 4 utilization is not reflected in the system-monitor?
again the system monitor only reflects the cpu1 use while cpu2, cpu3,cpu4 are with 0% load.

well after a reboot the issue resolved