Creating & flashing image for NVIDIA Jetson TX2 Devt Kit

I have 20 sets of NVIDIA Jetson TX2 Developer kits to configure.

Currently, I am using the SDK manager to flash Jetpack 4.2.2 to the TX2. I have installed additional libraries and made changes to the configuration of the TX2 according to my requirement.

I would like the same exact configuration for the other 19 TX2, thus would like to know if there is a faster way to do this. I could only think of creating an image of the working TX2 and flashing it to the rest of the TX2 - but not sure if its possible to do so. Tried googling to no avail.

hello wahdiah,

you could enable -G options to back-up APP partition to save all your configurations into an image file.
-G ------- Read partition and save image to file.

you may backup the system.img from target.
for example,

$ sudo ./ -r -k APP -G system.img jetson-tx2 mmcblk0p1

please replace that system.img with your host machine image.
then you should flash it to other boards with the same configuration.
please remember to add -r options, it’ll skip building and reuse existing system.img

Hi Jerry,

Thanks for the prompt response. I have backup the system image from target using the command above.

I copied the image to bootloader/system.img and tried restoring the image back to the same unit using the following command:

sudo ./ -r -k APP jetson-tx2 mmcblk0p1

However, the TX2 is unable to boot up - it is stuck in the User Manager for UID 120 loop. Am I missing any step?

Also to note, I did install the CUDA toolkit on the target TX2 before creating the image - would this cause any issue?


I am thinking I saw the UID 120 somewhere before, but can’t remember. However, keep in mind that the non-rootfs binary partitions need to come from the same JetPack/L4T release as the rootfs was generated for. So for example, a rootfs from R28.2.1 won’t work with the non-rootfs partitions of R32.2.

You can see which L4T release the rootfs goes with via “head -n 1 /etc/nv_tegra_release”.

Followed the solution on the thread at:

  • WayLand was already uncommented when I checked
  • I am unable to switch tty, the screen keeps on flashing back to tty1

I reverted to the original bootloader/system.img on my host machine and flashed the board via the command above, it was giving me the same error. However, when I flash the original image using the NVIDIA SDKManager GUI, it works fine.

Also to note, the backup image is based on the same Jetpack 4.2.2 as I have on my host machine.

Check the following command:

sha1sum -c /etc/nv_tegra_release

If this does not return all “ok”, then you have some incorrect libraries. If all is “ok”, then likely the flashing back to tty1 is a user space configuration issue.

Hi linuxdev,
Thank you so much for your response. I referred to an old thread. I flashed my board with the following command and it worked:

sudo ./ -r jetson-tx2 mmcblk0p1