CUDA 0.9 on Kubuntu Feisty x86_64

Just installed it. Seems to work. Will keep you posted.

Then perhaps you might be able to help me.

When I try to compile the CUDA SDK on Ubuntu 7.04, 64 bit, make throws the following error:

sh: cudafe: not found

I have CUDA installed to /usr/local/cuda, I have /usr/local/cuda/bin in $PATH, and /usr/local/cuda/lib in $LD_LIBRARY_PATH. bash can find other files in /usr/local/cuda/bin just fine - running ‘nvcc’ or ‘ptxas’ works exactly as one would expect. The only file it can’t seem to handle is cudafe.

And ideas?

cudafe was for some reason compiled as a 32-bit application in the 64-bit SDK. (I’ve already filed a bug on the developer site.) I found I could not run it until I installed some 32-bit compatibility libraries. I think:

sudo apt-get lib32z1 lib32stdc++6

will get things working, maybe. Try running cudafe directly to ensure it does not complain about missing libraries.

Those worked like a charm - cudafe is now recognized as a program. Unfortunately, there seems to be some sort of linking error, now. When I run make from NVIDIA_CUDA_SDK/ it tells me that ld can’t find Again, is in the right directory, LD_LIBRARY_PATH knows about it, etc. Perhaps it’s time for an OpenSUSE install?

Nevermind - edited to add -Wl,-rpath /usr/local/cuda/lib to the call the g++. All better now. Thanks.

Or for the lazy ones: sudo apt-get install ia32-libs.

This comes with a little more than needed, but might be handy when running other 32 bit apps.

By the way, did somebody try to compile the SDK as pure 64-bit system? I had problems with the build which went away by fixing (substituted -m32 with -m64) and adding a symlink from /usr/lib/ to /usr/lib/

I also did the fix. I don’t know if this is bad or not, but hopefully somebody will

answer. See topic

It installed easily on Ubuntu 7.04 for me, too (I just guessed and picked the RHEL 4 version of the toolkit–it went in no problems).

Getting the old driver uninstalled, however, proved to be impossible and required a reformat. I’m not sure where it was hiding, but no matter what I did, something kept finding it, and it was there on every boot (as an added bonus, it was also magically “in use” all the time, even in “recovery” mode).