CUDA 4 and VS C++ Express 2010

I’m new to CUDA and have been trying to get the samples in the cuda 4 SDK to work but the solution files won’t even load properly under VC++ Express 2010. The error message is telling me that it can’t find the .sln file even though it gives the full path and the files are where it’s looking.

Anyone know if Cuda 4 works with Visual Studio Express 2010 or is it a lost cause?

Thanks!

I’m certain VS2010 will work with CUDA 4.0. Some other people have it working: http://blog.cuvilib.com/2011/02/24/how-to-run-cuda-in-visual-studio-2010/

I’m having a similar problem getting it to run, too. Hoping someone will be able to help figure out what I/we did wrong.

I have been trying to install Cuda 4 with Visual Studio Express multiple times since the toolkit came out, but still am not able to compile any of the SDK code examples. I thought the 4.0 release was supposed to make CUDA programming available to everyone…

I have been trying installs on two different computers: one Windows Vista 32 bit and one Windows 7 64 bit.
I have tried installing 32 bit and 64 bit versions of the toolkit and SDK as all Visual studio versions are supporting both.
I have been trying both Visual Studio Express 2008 and 2010 (both are available) and updated with the latest service packs.
I have been trying both the latest driver 275.33 and the development driver 270.81 recommended on the download page.
I have been trying to install with Parallel Nsight, which is supposed to work with express as a client with .NET 3.5.1.

I have also tried following the tutorial kishd is mentioning.

None of the above was working. Now I have basically given up, hoping that there is someone out there who has successfully installed the 4 toolkit + Visual Studio Express combo and is able to give step by step instructions of how to do it.

Sounds similar to all the things I tried on my end to get it to work. Generally I do my development in linux but I got an nVidia card to try and get into some CUDA development for personal stuff. My home system is win7 (I’ve tried ubuntu 11.04 using wubi but it has some odd bugs with my 560 Ti that appear to crop up).

I’ve still not been able to get any of the samples to even load properly in Visual C++ Express 2010 yet. The error I get basically tells me that VC2010 express can’t find the project files. The odd thing I don’t get is that it cites that it’s looking at the proper path and file names… just it can’t ‘find’ the files. Could it be some permission issue or obscure VC setting?

This seems really odd to me, I tried reinstalling visual c++ express a few times and still nothing. Just looking for confirmation whether or not CUDA 4 works at all with VC++ Express.

It seems that Visual C++ Express 2010 does not support CUDA, and you have to use standart version (not express version) of Visual Studio to make CUDA work. I also tried to use CUDA with Visual Studio Express 2010 without success, so in Windows environment I keep using Visual Studio 2008 (Profesional edition) for CUDA programming. Actually, I prefer to develop a CUDA program in Linux environment, as the CUDA toolkit can be easily integrated with NetBeans IDE.

Hi.

I’ve discribed on my blog; How to build GPU Computing SDK 4.0 (64bit) with Visual C++ 2010 Express(in Japanese language).

http://feather.cocolog-nifty.com/weblog/2011/07/visual-studio-2.html

http://feather.cocolog-nifty.com/weblog/2011/07/visual-studio-1.html

http://feather.cocolog-nifty.com/weblog/2011/07/visual-c-2010-e.html

Here is a summary: (When building 32bit binary, some of these steps may not be needed.)

  1. Install Windows SDK 7.1 .

  2. Edit C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\BuildCustomizations\CUDA 4.0.props .

    <CudaClVersion>2010</CudaClVersion>
  1. Create C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin\amd64\ vcvars64.bat .

CALL “C:\Program Files\Microsoft SDKs\Windows\v7.1\Bin\SetEnv.cmd” /x64

  1. Open CUDALibrariesSDK_vs2010.sln and change each projects’ Platform Toolset to “SindowsSDK7.1”.

  2. Copy NVIDIA GPU Computing SDK 4.0\CUDALibraries\common\src{stopwatch.cpp, stopwatch_win.cpp} to NVIDIA GPU Computing SDK 4.0\shared\src .

I’m just start learning a couple of days ago, so please correct mistakes, if any.

Thanks.

I think I had the same problem, let’s clap our hands to NVIDIA “perfect” work clap clap clap… :wallbash:

You need to compile the libraries and copy the files said in the previus reply.

Take a look here: http://forums.nvidia.com/index.php?showforum=124 :thumbup:

Correct link: http://forums.nvidia.com/index.php?showtopic=205733