Compiling example code. Visual C++ 2008 Express, Vista 64 Premium. 280GTX.

Hello,

I am reciving a error in Visual C++ 2008 Express. The error is detailed below. I am trying to follow the quick start guide (http://developer.download.nvidia.com/compute/cuda/2_1/toolkit/docs/CUDA_Getting_Started_2.1_Windows.pdf). I try to compile the example project bandwidthTest.

I am sure I have installed everything properly: Visual C++ 2008 Express, then 181.20_geforce_winvista_64bit_english_whql.exe , then CudaSetup-2.1-win64.exe and finally NVIDA_SDK10_CUDA_x64_2.10.1215.2015.exe .

PC Specs:

Windows Vista Premium 64bit (fully patched).

280GTX

Intel Core 2 Quad Xeon X3350

Corsair 6GB DDR2 XMS2 Dominator PC2-8500C5 TwinX

ASUS Rampage Formula

I am reciving this error in Visual C++ Express (copy paseted from build log):

[codebox]Build Log Build started: Project: bandwidthTest, Configuration: Debug|Win32

Command Lines

Creating temporary file “c:\ProgramData\NVIDIA Corporation\NVIDIA CUDA SDK\projects\bandwidthTest\Debug\BAT0000014444244.bat” with contents

[

@echo off

echo “C:\CUDA\bin\nvcc.exe” -arch sm_10 -ccbin “C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin” -deviceemu -D_DEVICEEMU -Xcompiler "/EHsc /W3 /nologo /Od /Zi /MTd " –I”C:\CUDA\include” –I”…/…/common/inc” -maxrregcount=32 --compile -o Debug\bandwidthTest.cu.obj bandwidthTest.cu

“C:\CUDA\bin\nvcc.exe” -arch sm_10 -ccbin “C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin” -deviceemu -D_DEVICEEMU -Xcompiler "/EHsc /W3 /nologo /Od /Zi /MTd " –I”C:\CUDA\include” –I”…/…/common/inc” -maxrregcount=32 --compile -o Debug\bandwidthTest.cu.obj bandwidthTest.cu

if errorlevel 1 goto VCReportError

goto VCEnd

:VCReportError

echo Project : error PRJ0019: A tool returned an error code from “Compiling with CUDA Build Rule…”

exit 1

:VCEnd

]

Creating command line “”“c:\ProgramData\NVIDIA Corporation\NVIDIA CUDA SDK\projects\bandwidthTest\Debug\BAT0000014444244.bat”""

Creating temporary file “c:\ProgramData\NVIDIA Corporation\NVIDIA CUDA SDK\projects\bandwidthTest\Debug\RSP0000024444244.rsp” with contents

[

/OUT:"…/…/bin/win32/Debug/bandwidthTest.exe" /INCREMENTAL:NO /LIBPATH:“C:\CUDA\lib” /LIBPATH:"…/…/common/lib" /MANIFEST /MANIFESTFILE:“Debug\bandwidthTest.exe.intermediate.manifest” /MANIFESTUAC:“level=‘asInvoker’ uiAccess=‘false’” /DEBUG /PDB:“Debug/bandwidthTest.pdb” /SUBSYSTEM:CONSOLE /OPT:NOICF /DYNAMICBASE:NO /MACHINE:X86 cuda.lib cudart.lib cutil32D.lib kernel32.lib user32.lib gdi32.lib winspool.lib comdlg32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib uuid.lib odbc32.lib odbccp32.lib

“.\Debug\bandwidthTest.cu.obj”

]

Creating command line “link.exe @“c:\ProgramData\NVIDIA Corporation\NVIDIA CUDA SDK\projects\bandwidthTest\Debug\RSP0000024444244.rsp” /NOLOGO /ERRORREPORT:PROMPT”

Output Window

Compiling with CUDA Build Rule…

“C:\CUDA\bin\nvcc.exe” -arch sm_10 -ccbin “C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin” -deviceemu -D_DEVICEEMU -Xcompiler “/EHsc /W3 /nologo /Od /Zi /MTd " -I"C:\CUDA\include” -I"…/…/common/inc" -maxrregcount=32 --compile -o Debug\bandwidthTest.cu.obj bandwidthTest.cu

nvcc fatal : Visual Studio configuration file ‘(null)’ could not be found for installation at ‘C:/Program Files (x86)/Microsoft Visual Studio 9.0/VC/bin/…/…’

Linking…

LINK : fatal error LNK1181: cannot open input file ‘.\Debug\bandwidthTest.cu.obj’

Results

Build log was saved at “file://c:\ProgramData\NVIDIA Corporation\NVIDIA CUDA SDK\projects\bandwidthTest\Debug\BuildLog.htm”

bandwidthTest - 1 error(s), 0 warning(s)[/codebox]

If any additional information is needed then just ask.

Thanks for your help!

Regards

Charles

hello, try to build for x64 instead of win32.

I have a similar setup to yourself.
Following a hint in another topic, I got rid of the error “nvcc fatal : Visual Studio configuration file ‘(null)’ could not be found for installation at ‘C:/Program Files (x86)/Microsoft Visual Studio 9.0/VC/bin/…/…’”
by adding “C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\Tools\vsvars32.bat” to the Command Line in Bandwidhtest.cu Properties / General / CommandLine (in order to do that, I removed the BuildRules.

However, I now just get an erorr - mt.exe : general error c10100b1: Failed to load file “…\bin\win32\Debug\bandwidthTest.exe”

I am really only replying to you in the hope that you have managed to make some progress and can assist me. Or if you have not then we can tell each other what we have tried.

I have concentrated my efforts on the Projects / Template example and am stuck on the error of always getting "LINK : fatal error LNK1181: cannot open input file ‘.\Debug\template.obj’’.
I deleted the DEBUG subdirectory in template and find I do get written template_gold.obj (whatever that is, do you know) but not template.obj

Right now, in despair, I am trying to download the full version of Visual 2008 C++. I tried without success to add x64 to Visual Express 2008 and believe that to be a dead-end.

I have tried over the last few days many things, scoured the forums and Google and tried pretty much everything. As you have the same setup as me and are as sure as I am that all is intalled as it should be I can only hope you have stumbled on something I have missed. Thanks

Here’s an old post of mine with some instructions. Maybe they will help you out.

http://forums.nvidia.com/index.php?s=&…st&p=513354

Thanks for that link. It had a lot of interesting things.

But, I suppose it confirms my belief that it is not possible to use VC Express 2008 as one cannot Build with x64. I did as you suggested with cutil_vc90 and although x64 appears in the dropdown for Solution Manager, when one does the build it simply skips the item.

So I get (using x64) with VC 2008 Express

1>------ Skipped Build: Project: cutil ------
1>
========== Build: 0 succeeded or up-to-date, 0 failed, 1 skipped =========="

I can build it with Win32. But, interestingly (to me), it does come up with warnings which I would have thought it should not if the developer took more care

1>------ Build started: Project: cutil, Configuration: Debug Win32 ------
1>Compiling…
1>cl : Command line warning D9038 : /ZI is not supported on this platform; enabling /Zi instead
1>cl : Command line warning D9035 : option ‘Wp64’ has been deprecated and will be removed in a future release
1>cl : Command line warning D9007 : ‘/Gm’ requires ‘/Zi’; option ignored

So I guess I am forced to wait until the VS 2008 download finishes. It got to 3GB of the 3.31GB and my ISP has clearly choked my speed and it seems another 12 hours to wait for the last .31GB

I did manage to Google to a site that showed how one with a lot of Regedits one could make VC Express build X64 but it all seems too messy

I am sure at one time I tred merely loading the CUDA Vista-32bit Toolkit and SDK and doing everything under 32bit but simply got different sorts of errors. If anyone can confirm they managed to do this, I will may give that another try.

I guess I am just trying to avoid giving money to Microsoft for VS 2008 as the download will only be a 90 day trial.

Thanks again for the new information.

Yeah…I wouldn’t think you could run executables created with the 32-bit toolkit/SDK on the 64-bit driver, so you’ll need the full 64-bit driver/toolchain/VS2008 combo on Vista64, or downgrade to Vista32 bit and use the express edition.

I image you found something like this, with the registry changes and all, but if you want another go:

http://jenshuebel.wordpress.com/2009/02/12…64-bit-targets/