Cant build examples on Vista-64 using VS2005

This is similar to the previous thread"Cant build examples on Vista 64", except that I am using VS2005.

When I build <Debug, Win32> configuration I get

  fatal error LNK1181: cannot open input file 'cutil32D.lib'

When I change input library to cutil64D.lib I get

 nvcc fatal   : Visual Studio configuration file '(null)' could not be found for installation at 'C:/Program Files (x86)/Microsoft Visual Studio 8/VC/bin'

When I build <Debug, x64> configuration build is skipped (.obj and .exe are not built).

Does anyone knows if Vista-64 is supported?

Is there any reason the examples cannot be built?

Thanks!

I got the same problem too…any ideas? I mean, how can I manage to make it work on a 64-bit environment?

I have Vista 64-bit
Visual Studio 2005 Professional Edition SP1
I have installed Toolkit 2.0 64bit and Cuda SDK 64bit.
I’m not very used to c style programming (from what i can understand the projects try to link to a 32-bit dll), but it’s sounds very strange to me that the samples can’t be compiled on vista 64 “as they are”.
Where can I found resources to fix/solve this issue?
Why this kind of problem is not mentioned anywhere in Documentation?

Same problem here. I get “Visual Studio configuration file ‘(null)’ could not be found for installation at ‘C:/Program Files (x86)/Microsoft Visual Studio 8/VC/bin’”

HELP!!!

Go to NVIDIA CUDA SDK\common\cutil.sln, build the 32-bit debug library, and then build the sample projects.

I’m on XP x64, and I’ve re-built the cutil project, but I still can’t compile any of the SDK projects…I’m getting the same error:

1>------ Build started: Project: reduction, Configuration: Debug Win32 ------
1>Performing Custom Build Step
1>nvcc fatal : Visual Studio configuration file ‘(null)’ could not be found for installation at ‘C:/Program Files (x86)/Microsoft Visual Studio 8/VC/bin’
1>Performing Custom Build Step
1>nvcc fatal : Visual Studio configuration file ‘(null)’ could not be found for installation at ‘C:/Program Files (x86)/Microsoft Visual Studio 8/VC/bin’
1>Performing Custom Build Step
1>nvcc fatal : Visual Studio configuration file ‘(null)’ could not be found for installation at ‘C:/Program Files (x86)/Microsoft Visual Studio 8/VC/bin’
1>Linking…
1>LINK : fatal error LNK1181: cannot open input file ‘cutil32D.lib’
1>Build log was saved at “file://c:\Documents and Settings\Administrator\Desktop\reduction\Debug\BuildLog.htm”
1>reduction - 1 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

Also, trying to build an x64 version just skips compilation…

EDIT: Is there a chance something in one of the CUDA configuration files is looking in ‘C:\Program Files…’ and not ‘C:\Program Files (x86)…’, which would only be a problem on the x64 versions of windows?

EDIT 2: Strangely enough…when I have ‘Win32’ selected as the target, a little ‘delete’ icon appears over the icon the file ‘reduction_kernel.cu’; however, when I select x64, the icon disappears. Switching back makes the delete icon re-appear again. Maybe this gives someone an idea?

When I try to compile cutil.sln it gave me an error saying:

1>------ Build started: Project: cutil, Configuration: Debug Win32 ------
1>Compiling…
1>cutil.cpp
1>c:\program files (x86)\nvidia corporation\nvidia cuda sdk\common\inc\stopwatch_win.h(37) : fatal error C1083: Cannot open include file: ‘windows.h’: No such file or directory
1>stopwatch.cpp
1>c:\program files (x86)\nvidia corporation\nvidia cuda sdk\common\inc\stopwatch_win.h(37) : fatal error C1083: Cannot open include file: ‘windows.h’: No such file or directory
1>stopwatch_win.cpp
1>c:\program files (x86)\nvidia corporation\nvidia cuda sdk\common\inc\stopwatch_win.h(37) : fatal error C1083: Cannot open include file: ‘windows.h’: No such file or directory
1>Generating Code…
1>Build log was saved at “file://c:\Program Files (x86)\NVIDIA Corporation\NVIDIA CUDA SDK\common\Debug\BuildLog.htm”
1>cutil - 3 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

someone said to install microsoft’s SDK to have “windows.h” header.
Do you guys have some news about this error?

If you are running VS2005 express, you need to install the platform SDK.

Hello,
It happened the same to me.

I installed the 64bit versions of CUDA SDK and Toolkit. I worked the driver out too, I?m using a GF8600M GT, and just downloaded the latest CUDA supporting driver 179.48.

However, I was using the express version of C++ 2005, which didn’t leave me crystal clear it was working with the x64 redistributable package you have to download for the 64bits compilation, because it’s not included in the express version by default.

If you’re using the express version, I strongly recommend that change it for the complete installation of Visual Studio with the C++ compiler, and when installing you can include all the 64bits tools and addons. After that, I could build everything without troubles except for the DirectX examples, for I haven’t installed it yet.

Now, I’m looking forward for the next error. I can build but almost all example programs crash when trying to debug them.

I really hope that helps you out a little bit,

C

I faced the same both errors and here how I solved it:

  1. fatal error LNK1181: cannot open input file 'cutil32D.lib

This is probably because the project was set to Win32 instead of x64. Just right click the project in visual studio, select properties, and set the Platform display box to “x64”.

  1. nvcc fatal : Visual Studio configuration file ‘(null)’ could not be found for installation at 'C:/Program Files (x86)/Microsoft Visual Studio 8/VC/bin

And this is probably because Visual Studio doesn’t install “X64 Compilers and Tools” by default, so you should go to Control Panel, Programs and Features, select visual studio, add or remove features, and select “X64 Compilers and Tools” under Visual C++.

I hope this info helps.-

ummm… no

x64 build results:

1>------ Skipped Build: Project: fluidsD3D9 ------

1>

========== Build: 0 succeeded or up-to-date, 0 failed, 1 skipped ==========

x64 is skipping builds and rebuilds of all CUDA samples in 64 bit mode, and erroring out as described above looking for the 32 bit cutils.dll library while running in a Win32 mode.

I have sent a message to the NV Developers requesting access to the NV Developer forums for this.

CUDA 2.2 for x64 ships with drivers for the 64x builds, but doesn’t include the 32x libraries.

CUDA 2.2 for Win32 won’t install on my Vista Machine even though this seems to work really good in a 32-bit mode. To date, I have only had one other app fail to work correctly when installed in the Vista x86 (legacy) directory.

Re,

GameDaddy

VC++ 2008 Express, Intel Core 2 Quad CPU 3GHz, 64-bit Vista Home Premium SP2 OS, 6.00 GB RAM, NVIDIA GeForce 9800 GT

Hi guys,

I encountered the same message last night, and was really frustrated.

But indeed that’s not the problem of CUDA, it’s problem of VC++ 2008 Express.

Because, VC++ 2008 Express not support x64 compiler.

I don’t take a deep look into what’s real difference about the version of VC++ 2008,

but after I install VC++ 2008 Standard Version, the message is no longer appeared.

But if you wants to compiler in 64-bit, you need provide some .dll or .lib to VC++ 2008.

That’s not provide by VC++, you need to compile and build them from Nvidia CUDA SDK sample.

Follow the instruction the previous thread said, and copy the library file to location where VC++ can find.

And you will succeed in compiling.

Cheers,

  • Kala Kuo

hi guys i have managed to run the samples on my 64bit xp running vc2008 express edition. Yes thats right express edition. :banana:

You need to do a lot of stuff for this. So gentlemen brace yourself!!

A. First you need to be able to build x64 targets from your vc 2008 express edition. By default it is not possible.

  1. install the windows platform sdk. Get this from the Microsoft site, you need to select the amd 64bit iso. Select all the 64bit options in the installer

  2. Now goto here and follow the instructions to get the x64 target build access from the vc 2008 express edition editor! Btw if you DONOT find the VCProjectAMD64Platform.dll in your vc\bin\x86_amd64 directory, you will need to extract it from the iso downloaded from step1. In the iso, there is vc_stdx86.cab. In this cab look for file “FL_VCProjectAMD64Platform…” and rename it to VCProjectAMD64Platform.dll. and place it in “Microsoft Visual Studio 9.0\VC\bin\x86_amd64”.

  3. now fireup the vc2008 express edition editor and goto Tools->Options->Projects &Solutions->VC++ directories. Under the platform tab you should be seeing win32 and x64. If you see this then you can compile x64target from vc2008 express edition

B. now we install the 64bit version of cuda that also comes with the 32bit version. Also install the nvidia gpu sdk ( i assume you already have it with the samples).

  1. open the command prompt and type “SET C”. it will list like this
    CUDA_BIN_PATH=D:\GPUCompute\CUDA\bin64
    CUDA_INC_PATH=D:\GPUCompute\CUDA\include
    CUDA_LIB_PATH=D:\GPUCompute\CUDA\lib64

So make sure CUDA_BIN_PATH has bin64 and lib64 for 64bit building. If you are going to do 32bit then you need to change it to \bin and \lib (remove the 64)

  1. For 64bit building open NVIDIA GPU Computing SDK\C\common\cutil_vc90.vcproj. Select x64 target from the top, its the tab next to debug/release. And build both debug and release. You will now see cutil64.lib and cutil64D.lib in NVIDIA GPU Computing SDK\C\common\lib

  2. One last thing we need to do before building the samples for x64 target is to goto
    “\Microsoft Visual Studio 9.0\VC\bin\amd64”
    and see if vcvarsamd64.bat is present. I did not have this file so i copied vcvars64.bat from “\Microsoft Visual Studio 9.0\VC\bin” and put it in “\Microsoft Visual Studio 9.0\VC\bin\amd64” and renamed it to vcvarsamd64.bat.

  3. Now is the easy part. open the sample you wish to build. select target as x64, build. thats it! :banana:

Thank you so much, your fix worked perfectly. I have been trawling internet forums for nigh on 3 months now searching for a solution to the irritating compatibility issues between Microsoft Visual Express and 64-bit Windows OS (with CUDA). Thanks also to the author of the incumbent link regarding x64 target access - worked a treat!

Since following your step-by-step solution I have been able to not only build/run the SDK Examples on the x64 solution platform, but also to write my own CUDA programs outside of the SDK folder, and they build/run just fine using the x64 platform.

For the record, I am running:

Toshiba A500-17x

Windows 7 64-bit

Intel Core2 Duo

Nvidia Geforce 230M 197.16

CUDA toolkit v3.0

Visual C++ 2008 Express Edition

Once again many many thanks,

Michael