CUDA VS Wizard 2.0 beta

http://sourceforge.net/projects/cudavswizard

we can download here.

Thanks mas913’s new rules. I change the cuda.rules with the new rule.

The new rule can support all nvcc command options.

The new wizard(2.0beta) can support VS2005 (x86,x64), VS2005 Express (x86,x64).

If anyone think it’s interesting, plz join the project :)

Any problem plz let me know:)


please use the new version 2.0release.

http://forums.nvidia.com/index.php?showtopic=83054

when run debug or release model plz reset the: right key on the project -> property -> CUDA -> Output -> Intern mode: set Real:)

that is in the build rules.

to change it there are two ways.

D:\Program Files\Microsoft Visual Studio 8\VC\VCProjectDefaults\cuda.rules

find “InternMode” --> DefaultValue=“0”;

Wizard 2.0 beta doesn’t link on my VS 2005.
Resulting command line has all neccessary libs:

nvcc.exe -ccbin “C:\Program Files\Microsoft Visual Studio 8\VC\bin” -I"C:\CUDA\include" -I"C:\Program Files\NVIDIA Corporation\NVIDIA CUDA SDK\common\inc" -O2 -arch sm_10 -code sm_10 --host-compilation C -g -c -m 32 -L “C:\CUDA\lib” -L “C:\Program Files\NVIDIA Corporation\NVIDIA CUDA SDK\common\lib” --library “cuda.lib” --library “cudart.libl” --library “cufft.lib” --library “cutil32.lib” -o “Release\CudaConsoleThreads.obj” -odir “Release” -ext none -int real CudaConsoleThreads.vcproj

but output:

cudaconsole_kernel.obj : error LNK2001: unresolved external symbol _cudaMemcpyToSymbol@20
cudaconsole_kernel.obj : error LNK2001: unresolved external symbol _cudaGetSymbolAddress@8

cudaconsole_kernel.obj : error LNK2001: unresolved external symbol _cudaCreateChannelDesc@20
cudaconsole_kernel.obj : error LNK2001: unresolved external symbol _cufftPlan1d@16
cudaconsole_kernel.obj : error LNK2001: unresolved external symbol _cudaMemcpy@16

Wizard 1.2 worked with the same code without any problems. What should I change in the 2.0 settings?

  1. do you include the “cudaconsole_kernel.cu” file into other cu files? if so, right key on the cudaconsole_kernel.cu file and choose customer rule, means don’t use compile command for this file.

Thank you for the answer. *.cu files were compiling with custom rules. Don’t know why, but today it works :)

After installing 2.0 all the project settings appeared to be removed and project failed on compiling even with restored additional pathes and libraries. Then I installed again 1.2 and worked with it, everything was ok. And finally installed again 2.0 and for this attempt all the project settings kept correctly.

I have a project made with the wizard an this code

[codebox]#include <stdlib.h>

#include <stdio.h>

#include <string.h>

#include <math.h>

#include <cuda.h>

#include <cutil.h>

#include <cuda_runtime.h>

global void LiftGeometry()

{

int x = threadIdx.x;

}

void CudaCall()

{

LiftGeometry<<<1, 1>>>();

}

int main()

{

CudaCall();

}[/codebox]

and I have this problems:

x:\proyecto final de carrera\códigos\utd-gpu\utd-gpu\KernelTest.cu(12) : error C2065: ‘threadIdx’ : identifier don’t declared

1>x:\proyecto final de carrera\códigos\utd-gpu\utd-gpu\KernelTest.cu(12) : error C2228: the left operator of ‘.x’ must have class/struct/union

1> the type is ‘‘unknown-type’’

1>x:\proyecto final de carrera\códigos\utd-gpu\utd-gpu\KernelTest.cu(17) : error C2059: sintaxis error: ‘<’

1>Test.cpp

If someone knows where is the problem…

Thank you

i guess the file was compiled by C++ compiler but not NVCC compiler.

how do you create the project?

I’ve selected create new project->Visual C+±>CUDA->CUDAWinApp

Into the project I’ve created a new file called KernelTest.cu and I’ve written that code.

Now I’ve done the same in a new project without other files that I have. This new project works. Maybe it’s some configuration that I’ve changed. I’m going to make a new project whit all my files. Thank you

can you send your project to me?

I’m using this version with the fix you suggested and it works quite ok. Thank you.

Another thing: project compiled with wizard 2.0 could not do breakpoint in a host function (*.cu file) while compiling with 1.2 works with such a breakpoint correctly.

When you want to debug it in *Release model: right key->property->general->Debug information -g

Thanks, it works!

Hi,

I’m staring using CUDA.

After some fight with the Enviroment Variable I’m ready to start to work.
I have Vista 64 and I have installed the 32 and 64 CUDA toolkit and SDK.
Using different Envioroment I enable the compilation for 32 or 64 bit.

By default, the name of the variable that I use for 32 bit ( CUDA_PATH, … )are the same as CUDA Wizar use it.

For 64 bit I use CUDA_PATH_64, …

I’m interesting to create another cuda.rule file for 64 bit using my variable and in this way I can choose to create the template for one platform or the other.

Could you tell me witch variable I need to change in the original cuda.rule to make my intention?

Thanks,
GUAN

to:guan

This default variable is not in the rule but in the default.js file.

D:\Program Files\Microsoft Visual Studio 8\VC\VCWizards\CUDA\CUDAWinApp\Scripts\1033\default.js

you can find the path:)

BTW, do you have interesting to join this project to make the wizard stronger?~~~…

Thanks,

Well Now I have open several project :P, I don’t have time to belong to another project as programing , but if you need a beta tester tell me, if I have time then I test the new release without problem :)

Thanks,

GUAN

GUAN: >_<! Good test is important as develop.

Thanks:)

Hi,

I have another question about CUDA WIZARD.

When I press New Project in VS I want to have two Item: CUDA and CUDA64.

For it, I made a copy of the whole CUDA directory form VCWizard and rename the copy to CUDA64.
I copied too the file cuda-win-app-msvc.vcproj and rename to cuda64-win-app-msvc.vcproj
I made the same with cuda.rule => cuda64.rule

I changed several variable to adjust the scripts to my configuration.

I can’t test my changes because not appear CUDA64 in new=>Project => Visual C++

I suppose I new to add something into a file or register but I don’t know what exactly.

Could you tell me what is ti?
GUAN