CUDA VS Wizard 2.2 beta

https://sourceforge.net/projects/cudavswizard/files/

  1. change the build rule to cuda.rules(SDK common \C \ cuda.rule) which is the 3.0beta1.
  2. you can add the CU file from the project directly.

it can support VS 2005 vs2008, windows xp, windows vista, windows 7; 32 bit system and 64bit system.

CUDA_VS_Wizard_W64.2.2.beta2.zip

MD5: 8f03459f658362ea448dab736291bd1a

SHA1: d5bc2397ca741b6a5cc1d9c356b172022d0094a6

CUDA_VS_Wizard_W32.2.2.Beta1.zip

MD5:82107519a9399a7b784906a4b3a8dd10

SHA1:3b1a947f4bb5620c3721202b46d4417757fc6638
CUDA_VS_Wizard_W32.2.2.beta1.zip (106 KB)

What a useful tool! Many, many thanks!

However, the Wizard does not fully function on my computers. I can build an empty project using the wizard. But the option “ Precompiled header” was checked, I always got an error message saying “Err source: OnFinish”. I tried on two computers and got the same result. Both computers run Windows XP (32-bit) and have both CUDA Driver & SDK installed. Would you please tell me how to set up the Wizard to solve this problem?

PS: I am just a beginner.

I will check it.

Thanks.

FYI, I tried the wizard on two computers. One has VS 2008 Pro and the other VC 2008 Express. I got the same error. Both run Windows XP (32bit) and have CUDA driver and SDK installed. I checked the CUDA environmental variables and found no errors.

this bug had fixed in the beta1 version.

enjoy~

I tried. The newer version works great!

Thanks again!

The CUDA_VS_Wizard_W64.2.2.beta2.zip fixed some bugs in the CUDA_VS_Wizard_W64.2.2.beta1.zip.

I’m trying to run a cuda program on my system (windows xp 64x), using vs 2008. I used CUDA_VS_Wizard_W64.2.2.beta2. There is no problem with making a new project, but when I run the program I always get this error:

“cannot find the input file ‘cutil32D.lib’” and the program fails :confused: . I’ve tried your 32bit-wizard on a 32bit system before, and it worked well. Which wizard(s) should I exactly install? thanks in advance :rolleyes:

system details(again!): windowsXP 64x, cuda2.3, vs2008

change the cutil32D.lib into cutil64D.lib

Thanks alot :rolleyes: it’s now working perfectly!

thanks for your attantion.

Hello.

I am trying to use your wizard, but I can errors when creating a new CUDA project. I am using Windows 7 Ultimate (64-bit), Visual Studio 2008 Express Edition, and CUDA 3. When I try to create a new project (File -> New -> Project…), I select CUDA64 and then CUDAWinApp. I browse to my project directory and give it a name, click “OK”, then click “Finish”. I get the following errors.

Err source: CreateCustomProject

Err source: OnFinish

Then the new project wizard pops up again. The folder that I created from the failed attempt is present, so I need to choose another project name this time. I tried to create another project, this time removing the check from “Precompiled header” but that gives me the same errors.

This is a fresh installation of VS2008EE. What should I do?

EDIT:

This is the vcproj file that it creates. Is the problem that the VS2008EE doesn’t install the 64-bit compiler, or something silly like that?

[codebox]<?xml version="1.0"?>

<Platforms>

	<Platform Name="x64"/>

</Platforms>

<ToolFiles>   

<DefaultToolFile FileName="cuda64.rules"/>

</ToolFiles>

<Configurations>

<Configuration Name="Debug|x64"></Configuration>

<Configuration Name="Release|x64"></Configuration>

<Configuration Name="EmuDebug|x64"></Configuration>

<Configuration Name="EmuRelease|x64"></Configuration>

[/codebox]

EDIT2:

That very well might be the problem. If I change the configurations from x64 to Win32, VS opens the project without any trouble. However, I have another issue. When I want to add a source file, there is no option to add a new .cu file. Is this normal?

yes,i think it’s your VS 2008 Express doesn’t content 64bit compiler.

you can use the 32bit version.

you can add the new .cu file as normal.

Hi, I am running vs2008 professional & cuda64 on win7 ultimate 64. The cuda and vs2008 were installed successfully. Then I tried the wizard2.2beta2 64bit. When I tried to create a new project with the wizard, after I selected cudawinapp from the template and clicked ok, it jumped out a messagebox:

script error
line: 323
char: 2
error: object expected
code: 0
url: c:\program files(x86)\microsoft visual studio 9.0\vc\vcwizards\cuda64\cudawinapp\html\1033\

do you want to continue running scripts on this page?
yes no

If I click yes, then I don’t have the opportunity to see the next configuration page. I will be sent directly to the finish page on which the “finish button” only cause another script error thus you can never finish.
If I click no, it simply brings me back to the first page.

Could you help me? Thanks a lot.

Michael

Ok, as stated before , 64 bit compiler should be installed. This could be done while installing VS2008 by selecting custom install and tick the 64bit compiler support in VC++.

I’m getting the following error when I try to create a project using this wizard :

Err source:CreateCustomProject

please see attached file.

I’m using VS2008 Pro edition , windows 7 Pro x64

CUDA 2.2 installed

thank you

install VS 64bit package~~~

Will CUDAVSwizard support visual studio 2010?

next version:)

I’m having one issue with this version and I was hoping you could perhaps help me out.

I have a full VS2008 CUDA project from the CUDA Toolkit 2.3 aided by your previous CUDA VS Wizard 2.0.

Now, I have, on a fresh machine, installed the CUDA Toolkit 3.0 and your CUDA VS Wizard 2.2 Beta 2. I loaded up the solution for the previously mentioned project and attempted to build it. I receive this error:

error PRJ0019: A tool returned an error code from “Compiling with CUDA Build Rule…”

Is there anything I can do to resolve this besides creating a brand new project and moving the code into it?

Thanks :)

–Edit–

Of course, as soon as I posed this I managed to solve the issue! For those curious, the project was referencing cutil.h but, apparently, it couldn’t find the header (although it didn’t show up as an error). Adding the path to cutil.h in the additional includes solved the issue.