using 2.1 beta on win xp x64

I am trying to setup a cuda development environment on windows xp x64. I have downloaded and installed (1) vc++ 2008 express SP1 (since 2.1 beta supports it), (2) driver 180.60 beta (180.60_CUDA_XP64_beta.exe), (3) cuda toolkit 2.1 beta (CudaSetup-win64-rel-nightly-2.1.1635-3046817.exe), (4) cuda sdk 2.0 (NVIDIA_CUDA_SDK_2.02.0811.0240_win64.exe) in this order. Does it have to work like this ? The problem is if I open an example such as device query, first, I do not see syntax highlighting, second, when I compile, I get the following error; “nvcc fatal : Visual Studio configuration file ‘(null)’ could not be found for installation at ‘C:/Program Files (x86)/Microsoft Visual Studio 9.0/VC/bin/…/…’”.

Thanks for any help.


You have to add a rule to set up syntax highlighting–there’s documentation either in the SDK or in the toolkit, I forget which.

As far as VC2008 Express goes, you probably have to use the --ccbin option to make ti work.

Thanks for quick reply.

Syntax highlighting is ok with the directives in sdk.

However, I did not get the point with ccbin option. The custom rule is already setup with -ccbin “$(VCInstallDir)bin” parameter and I think it resolves to “C:/Program Files (x86)/Microsoft Visual Studio 9.0/VC/bin”. What do I have to write here ? What is the configuration file mentioned in the error “Visual Studio configuration file ‘(null)’” ?


oh, wait, are you compiling for 64-bit? VC Express (as far as I know) doesn’t contain 64-bit compilers, so you’d have to use the 32-bit toolkit and SDK.

I am not sure how to answer if I am targeting 64-bit, but I have installed vc express (on win xp x64) and cuda 64-bit toolkit. So, if I understand you right, I have two options; one is to install 32-bit toolkit and sdk and the other is to get a normal version of vc (not express). Is that correct ?


correct. with 2005 Express, at least, it didn’t include a 64-bit compiler at all so you could only use the 32-bit toolkit.

OK. With cuda toolkit for windows xp 32-bit, it works without any problem. Thank you.

I think it can be helpful to add a little note to cuda download page, because it asks for operating system and I, for example, tend to choose windows xp x64 without thinking about my compiler.


VC2008 Express isn’t an officially supported compiler (It Should Work, but we don’t thoroughly test it); it should be in a FAQ, though, I agree.

I have VS2008 (full version, I believe): Does this support 64 bit system? I have the following specs:

XP 64 system; GTX 280 and Three Teslas. I have installed CUDA 2.1 Beta driver, toolkit and SDK. When I compile the system with VS 2008 under Win32, I get the following error:

[codebox]1>LINK : fatal error LNK1181: cannot open input file ‘cutil32.lib’[/codebox]

That makes sense because I don’t have cutil32.lib since I installed 64 bit version of the CUDA. But if I change the configuration manager option to x64, it doesn’t even compile and I get:

[codebox]1>------ Skipped Build: Project: particles ------


========== Build: 0 succeeded or up-to-date, 0 failed, 1 skipped ==========


Doesn’t VS 2008 have 64 bit compiler? Are there settings I need to change to get that right? Any help would be greatly appreciated.


The 64-bit compiler is not installed by default (even on a 64-bit OS, which is probably the dumbest packaging decision ever). You need to do a custom installation of VS2008 and specifically install the x64 compiler.

Thanks. I guess I now need to uninstall VS 2008, but the annoying thing is that it does not uninstall everything else that comes together automatically with VS 2008. It seems I need to do that manually.

That worked!

To compile for windows x64 using VC 2008 express editions see steps for compiling x64 code with VC++ 2008 express

Worked for me