cuda 8.0 setup at debian

hi, at older debians it all worked ok.
just have setup a box with debian

In fact other box here it used to work ok.
trying setting up now at tyan 16 core box 8356 cpu’s inside (very old yeah i know, lotta noise and juice)

here is output of logfile in the end after the so manieth attempt:

“Performing CC sanity check with CC=”/usr/bin/cc".

Using the kernel source path ‘/usr/src/linux-source-3.16’ as specified by

the ‘–kernel-source-path’ commandline option.

The driver installation is unable to locate the kernel source. Please make sure that the kernel source packages are installed and set up correctly.
If you know that the kernel source packages are installed and set up correctly, you may pass the location of the kernel source with the ‘–kernel-source-path’ flag.

===========
= Summary =

Driver: Installation Failed
Toolkit: Installation skipped
Samples: Not Selected
"

Last attempt i did do i tried:

./cuda_8.0.27_linux.run -silent --kernel-source-path="/usr/src/linux-source-3.16" --driver --toolkit --no-opengl-libs

Of course i tried giving it the kernel sources.

here is how directory looks like and the uname -a

root@xandria:/usr/src/linux-source-3.16# uname -a
Linux xandria 3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u1 (2016-09-03) x86_64 GNU/Linux
root@xandria:/usr/src/linux-source-3.16# cd …
root@xandria:/usr/src# ls -l
total 558600
drwxr-xr-x 2 root root 4096 Sep 9 00:06 linux-config-3.16
drwxr-xr-x 4 root root 4096 Sep 8 22:20 linux-headers-3.16.0-4-amd64
drwxr-xr-x 4 root root 4096 Sep 8 22:20 linux-headers-3.16.0-4-common
lrwxrwxrwx 1 root root 24 Dec 14 2015 linux-kbuild-3.16 -> …/lib/linux-kbuild-3.16
drwxr-xr-x 22 root root 4096 Sep 3 09:27 linux-source-3.16
-rw-r–r-- 1 root root 571985920 Sep 3 09:31 linux-source-3.16.tar
root@xandria:/usr/src# pwd
/usr/src
root@xandria:/usr/src#

Note that the linux-source-3.16.tar file i had to unzip with ‘xz’ myself and also untar the tarfile

Any thoughts how i can get CUDA installed on the box?

thanks in advance,
Vincent Diepeveen

Looks like it’s installing now!

And that even at a distro not supported by nvidia - really great!!

Jippie jee, it works great! This thread can be closed!

diep@xandria:~/riesel/cudasieve$ ./riesel
Trying to allocate some RAM for buffer
PrimeBuffer allocation succesful filling up with 20000000 primes
Initialized PrimeSieve
primesieve timings: skip=0 us gentime=129586 us primes/s = 154336672
Starting cracking discrete logarithm problem using modified BSGS algorithm
CUDA program to sieve Riesels
Found 1 devices capable of executing CUDA
Device 0 has compute capability 2.0.
Allocating memory on CPU
Allocating 763625472 bytes memory on GPU
Deallocating memory on GPU and CPU