CUDA driver version is insufficient for CUDA runtime version (iMac + AMD Radeon R9)

Hello,

I have an iMac (later 2015 version) with AMD Radeon R9. I installed Cuda driver V8.0.54, and followed the installation steps online.

When I try to run deviceQuery, I got this error:
CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL

I searched through this forum and did not find any solid solution.

Can anyone help?

Thanks!

If you want to use CUDA, you need an NVIDIA GPU. The AMD Radeon R9 won’t work for CUDA.