Cuda 6 driver version is insufficient for Cuda runtime version

I’ve installed cuda 6, compiled the examples, then ran ./deviceQuery

This is the Terminal print:

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL

From System Preference i get:
CUDA Driver Version: 6.0.26

I’m using a Macbook pro 15" late 2008 with GeForce 9400M / GeForce 9600M GT
Cuda doesn’t work with Cuda 5.5, so I tried with Cuda 6.
Let me know if there’s a solution for my problem, I need Cuda for my university, thanks

Which MacOS version is on that machine?
what is the result of running:

nvidia-smi -a

message from Cuda 6 support

I noticed that you’re running CUDA6.0RC on a Macbook pro with GeForce 9400M / GeForce 9600M GT and OSX Mavericks. However, in CUDA6.0 RC release notes, it stated that “The CUDA 6.0 toolkit and r331 driver do not work on Macs with GPUs based on the MCP79 chipset. To continue developing or running CUDA applications, please use the CUDA 5.5 toolkit or r319 driver, as appropriate.” . Unfortunately, we have a known issue in the initial driver supporting CUDA 5.5, it does not support Tesla-class (sm_1x architecture) GPUs on Mac OSX 10.9.

Sorry for the inconvenience, we’ll inform you once the new release which contains this issue’s fix is available for you.

I can’t use neither Cuda 6 nor Cuda 5.5

PS:

today new driver release
CUDA Driver Version: 5.5.43

deviceQuery works!

Hi, I’m having the same problem on a mid-2010 17" MBP with a GeForce GT330M. I’m running Mavericks - 10.9.2, and have installed the 6.0RC. I was able to build the samples but cannot run them - I get the same error that “CUDA driver version is insufficient for CUDA runtime version”. As a newbie - how do I know the chipset that my GPU is based on?

Download and install Cuda 5.5 new release . You should read Cuda 6 release notes to know the supported chipset

Hi,

I have the OpenCV 3.0 project with included all Cuda static libs.
I’m having the same problem when try to call Cuda functions “CUDA driver version is insufficient for CUDA runtime version”.
Configuration is:

  • MacPro OSX 10.10.2
  • GTX 680
  • Web Driver: 343.02.02f02
  • Cuda driver: 6.5.45

Tried also to run nvidia-smi but can’t find it…
What might be wrong?