CUDA driver version is insufficient

Hi,

I am very new to CUDA and have an NVIDIA GeForce 8800 GT with my windows 7 64-bit system which I am trying to set up. The Nvidia driver version is 341.95 (obtained via the nvidia control panel) and I have the 7.5 release of Cuda. Whenever I try to run the deviceQuery program, I get a message stating

“cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL”

Also, when I run the program deviceQueryDrv, it gives me a passing result but says that I have CUDA driver version 6.5

I am quite confused, any suggestions as to what I should do to fix this?

The NVIDIA GeForce 8800 GT is not supported by modern versions of CUDA, such as version 7.5. I think this GPU is a device with compute capability 1.1, which was last supported in either CUDA 6.0 or CUDA 6.5 (my memory is hazy). I would suggest moving to a more modern GPU with compute capability at least 2.0. This will allow you to use CUDA 7.5, and then you can simply download the latest Windows driver package (currently it is 368.39) from the NVIDIA website.

Hi,

I have mac OS X 10.11 and eGPU - GTX 980ti. I have installed latest driver for mac (CUDA Driver Version: 7.5.30) and CUDA toolkit 7.5. However when I try to run the deviceQuery program I get the same issue:

./deviceQuery Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL

Any suggestions?

Thanks Petr

eGPU?

External GPU. I have bizon box ( https://bizon-tech.com/us/bizonbox2-egpu.html/ ) where I plug-in the GTX 980ti and connect it using thunderbolt.

I have a mid-2010 MacBook Pro 15" with nVidia GeForce GT330M. I recently discovered that all of my programs that used to work nicely now crash. Eventually I realized that I probably had not run them since upgrading the OS to 10.11. I installed CUDA 7.5, but got the “insufficient driver” messages from deviceQuery. I upgraded to the lastest driver (7.5.30) but the problem persisted. Ultimately I found this forum, which suggested that my cuda device is not compatible with CUDA 7.5. I moved the 7.5 installation out of the way and tried to rebuild with the old 6.5 installation, hoping that it might work with the newer driver, but I get the same “insufficient driver” message.

Is there any way that I can get this to work? My software also runs with OpenCL, but when I tried running it with OpenCL instead of CUDA, it crashed the laptop!? Not sure what hardware driver OpenCL uses…

Any advice will be most appreciated!

-Jeff

@pefi:

What about the “GPU Driver Version” and “CUDA Driver Version” shouwn from “CUDA Preference”?

Could you please post the output of running the following commands?

kextstat | grep NVDA
kextstat | grep -i cuda

I recommend you to click the Apple menu and choose Software Update. If an update is available for your GPU, please install it.

Hi. I am having the same problem: CUDA driver version is insufficient for CUDA runtime version, trying to run CUDA OpenCV in Quadro FX5800 and Quadro 6000 - Windows 7.

I am using Emgu as wrapper.

Is there any OpenCV build with CUDA that is compatible? Any advice is appreciated.

Thanks in advance.

Quadro FX 5800 is a device with compute capability 1.3, it is not longer supported by CUDA, and has not been supported for over two years. This is outdated hardware and I would suggest discarding it.

The Quadro 6000 is a device with compute capability 2.0. This is supported by CUDA 8 (the latest shipping version) and the driver accompanying CUDA 8 should work just fine with it.

I do not know what “Emgu” is and how it may be interfering with CUDA. If it is not strictly needed, I would suggest not using it, at least not until you have CUDA up and running in general on the Quadro 6000.

I tried to find out what OpenCV requires in terms of GPU architecture, but was unable to do so from a quick internet search, which may either indicate poor Google-fu on my part or poor documentation on the part of OpenCV developers.

This solved the problem. Thanks