Sigh...not off to a good start with CUDA on a Quadro FX 4800 on Mac

Hi all-

I have a Mac Pro (early 2009, model 4,1) running 10.10.1 that I want to use for CUDA programming. I picked up a Quadro FX 4800, installed the Nvidia drivers (and have the driver set to Nvidia’s, not Apple’s, in the Driver Manager), then downloaded Cuda for Mac 6.5.36 drivers, which installed fine, and I was able to build all the samples successfully. Plus I have the CUDA preference panel which reports CUDA driver as 6.5.36 and GPU driver version 10.1.43 (343.02.01f01).

Unfortunately, when I try to run deviceQuery, I get “CUDA driver version is insufficient for CUDA runtime version.” All the other samples return basically the same error.

If I run kextstat | grep -i cuda I get:

129 0 0xffffff7f8271c000 0x2000 0x2000 com.nvidia.CUDA (1.1.0) <4 1>

which suggests to me that it’s loaded, so I’m confused why this isn’t working; the previous video card was an ATI so it’s not like I’ve ever had any CUDA drivers on here before, but yet it’s not working.

Any help would be appreciated, I’d really like to get into programming CUDA for my project (map making).


That is a really old GPU, which is probably compute 1.x. I think that CUDA 6.5 may not support that old a GPU.

I my experience CUDA is most powerful on a desktop PC with Windows 7 or 8.1, or a supported flavor of Ubuntu.

Right, which is why I installed 6.5.36, as it said to install that for 1.x cards, unlike 6.5.37. According to the release notes for 36:

Supports all NVIDIA products available on Mac HW.
Note: this driver does not support GeForce GTX980 and GTX970. Please download the equivalent CUDA driver 6.5.37 which supports GeForce GTX980 and GTX970.

hmm, then I do not know. It should work with that GPU actually.

I know the Nvidia drivers for Windows tend to be better, but have no experience with Macs(keep in mind most consumer GPUs are used for games in Windows).

Probably should file a bug with Nvidia, unless someone here has some experience with that hardware.

The issue here is that the GPU driver version is invalid for that card.

The CUDA version of will work with QFX 4800. The GPU driver version of 343.xxxx will not. Support for cc1.x devices was dropped in drivers. You need a GPU driver version that reports itself as 340.xxxx or older.

Drat, I tried that but 10.10.2 doesn’t like it and switches back to the OS X driver. Ah well, guess no Cuda for me on this machine.