deviceQuery fails for Cuda 9.0 installation on Ubuntu 16.04

I am attempting to install Cuda 9.0 on my lenovo laptop running Ubuntu 16.04 and am getting an error when I run ./deviceQuery.

./deviceQuery Starting...

 CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL
~$ lspci -v | grep -i nvidia
01:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] (rev a1)
	Kernel driver in use: nvidia
	Kernel modules: nvidiafb, nouveau, nvidia_390, nvidia_390_drm
~$ nvidia-settings -q NvidiaDriverVersion

  Attribute 'NvidiaDriverVersion' (joe-Lenovo-IdeaPad-U410:0.0): 390.87
  Attribute 'NvidiaDriverVersion' (joe-Lenovo-IdeaPad-U410:0[gpu:0]): 390.87
~$ cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module  390.87  Tue Aug 21 12:33:05 PDT 2018
GCC version:  gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.10)
~$ nvcc -V
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2017 NVIDIA Corporation
Built on Fri_Sep__1_21:08:03_CDT_2017
Cuda compilation tools, release 9.0, V9.0.176
~$ nvidia-smi
Mon Oct  1 15:48:43 2018       
| NVIDIA-SMI 390.87                 Driver Version: 390.87                    |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|   0  GeForce 710M        Off  | 00000000:01:00.0 N/A |                  N/A |
| N/A   42C    P0    N/A /  N/A |    116MiB /  1985MiB |     N/A      Default |
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|    0                    Not Supported                                       |

I am able to compile all of the cuda samples. Although I did have to add the following line to the makefile in ~/NVIDIA_CUDA-9.0_Samples/3_Imaging/cudaDecodeGL

LIBRARIES += -L/usr/lib/nvidia-390

I tried following the comment in this forum: but it did not change any results.

I also added the following file before re-running sudo ldconfig

~$ cat /etc/

Is there anything else I can try to fix this error?

Thanks in advance for any help.

What exactly happens when you try to compile and run a program?
Do you have to stick to v9.0? I installed the updates to 9.1xxx, using the driver version you have, and it works.