CUDA driver version is insufficient for CUDA runtime version

Hi,

I encounter the following error when I try to run deviceQuery:

cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version

Here is some information about my server:

OS: Debian Jessie
GPU: Quadro K5000
CUDA version: 7.5
Driver Version: 352.79 (latest version on jessie-backports)

Please let me know if you know what’s causing this issue and/or how to solve it.

Thanks,
Mahdi

Moved to the CUDA forum.

Your install was not done correctly.

Please follow the instructions carefully in the linux install guide.

Do you mean the driver or CUDA?

Do you suggest using the driver which is part of jessie-backports or downloading sh file from nvidia’s website?

Do you mean the driver or CUDA?

Do you suggest using the driver which is part of jessie-backports or downloading sh file from nvidia’s website?

I suggest you follow the instructions carefully in this document:

http://developer.download.nvidia.com/compute/cuda/7.5/Prod/docs/sidebar/CUDA_Installation_Guide_Linux.pdf

For supporting NVIDIA GPUs, I recommend you only use installers or repositories that are explicitly provided by or managed by NVIDIA.