CUDA driver version is insufficient for CUDA runtime version

I am getting this error when trying to run Tensorflow:

cudaGetDevice() failed. Status: CUDA driver version is insufficient for CUDA runtime version

  • Tensorflow Version: 1.11.0
  • Nvidia Driver: 390.77
  • CUDA Version: 9.0.176
  • CUDNN Version: 7.301
  • GPU: GTX 1050Ti
  • OS: Mint 19, based on Ubuntu 18.04
  • Hope someone can help me.

    I have exactly the same problem.

    tensorflow-gpu: 1.11.0
    NVIDIA-SMI 390.87
    CUDA Version: 9.0 and 10.0 (both hit the same problem)
    CUDNN: 7.301
    CPU: GTX 1050Ti
    OS: Ubuntu 18.04 LTS

    I’ve tried all different ways and some people suggested downgrading tensorflow and I downgraded to tensorflow-gpu 1.7 and it works.

    Check out the issue here.

    I finally successfully upgraded my nvidia driver to 396.54 and that works with tensorflow 1.11.0:
    sudo ubuntu-drivers autoinstall
    sudo reboot

    I got the same issue after I installed tensorflow via Conda. Between downgrading tensorflow to 1.7 and upgrading Nvidia driver to 396, I’d prefer the latter. But I am concerned if driver 396 would cause stability issue on Ubuntu 18.04. Also, will ‘sudo ubuntu-drivers autoinstall’ install something more recent (such as 410) instead of 396? Any advice? Thanks.

    Update: I got error message when trying to install 396: kwei@kwei-ML-GW:~$ sudo apt install nvidia-396
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    E: Unable to locate package nvidia-396

    I have exactly the same problem.

    tensorflow-gpu: 1.11.0
    NVIDIA-SMI 388.13
    CUDA Version: 9.0
    CUDNN: 7.5
    CPU: GTX 1080Ti
    OS: Window 10

    I have downgraded tensorflow to 1.7 and the same problem.
    Please, how can I resolve this problem?

    Thanks.