cuda-gdb segfault

My code runs on its own without faulting (although there are definitely serious bugs!).

In cuda-gdb, however, cuda-gdb itself is segfaulting (SIGSEGV) when my code tries to launch a kernel. Kernel1 executes fine, but Kernel2 segfaults at launch. The process (mine, not cuda-gdb) remains and I have to kill it manually. I have been using cuda-gdb with this code for some time now and this is the first I have encountered this problem.

I tried briefly to search for this in the forums without success. This is such a general problem I’m sure it has been addressed before. If that’s the case, just point me the way.

How can I start to diagnose this problem? What sorts of things could be happening to cause this?

EDIT: For my own purposes, running in emulation mode with gdb might be enough (nope, turns out it wasn’t enough. I’m in the dark.) I’m still curious, and I’d also like to be able to provide meaningful feedback to cuda-gdb developers.

ubuntu 9.04 64-bit
cuda 3.0
gdb 6.6
gcc 4.3.3

can you try cuda 3.2?

unfortunately no, although I can’t completely remember why not.

and, you’re right maybe it’s not worth investigating unless it occurs in 3.2.

You probably have already thought of this, but
have you shut down all other use of the card before you
try and run GDB? (I run gdb via emacs and several times
have been bit by forgetting it was already running in
another emacs buffer.)


I’m pretty sure.

I sort of know what lines in the kernel are causing the segfault, but not why. If I have the kernel return before reaching those lines, the program and cuda-gdb run just fine. So I suspect it’s not about other use of the card.