cuda laptops (less-painful-handling/best performance) at around 1000 eu

Dear all,

I’d need to buy a CUDA enabled (version 4+) laptop for my work at around 1000 eu. I was interested in Dell XPS 15 with GeForce® GT 540M 2GB with Optimus but I read in many posts that Optimus is a big problem, not easily handable. Is it true?
Could you suggest me the best (stable) laptop solution up to you?

Thank you so much for any help you would give me.




I’ve got a Dell XPS 14z that I run on LinuxMint 11 (based on Ubuntu 11.04) and I use it for cuda dev and test (moderately since the gpu is only a GT520M). But it works.
Thanks to the Optimus technology not supported on Linux, I can’t use the GPU for visualisation at all (OK, Bumblebee works but it’s not very convenient to say the least), but fortunately enough, the Intel GPU integrate into the Sandy Bridge CPU is far sufficient for my visualisation needs. So the NVIDIA GPU only serves me for GPU computing, and all the video rendering is done on the SB.
I guess it’s ok as long as I don’t try to mix CUDA and OpenGL…


I have ubuntu 11.10 on a laptop with optimus and a 540m. No problems, but I had to spend some time to find the instructions to do the installing.

Thank you both for your replies!

So I guess Dell XPS could be a good solution.

In the case you hear about experiences with other CUDA-enabled laptops, please let me know.



Do you have CUDA toolkit 4.1, right? just to be sure, because it is hard to find compatibility infos on the web…



Yes I have CUDA toolkit. My installation was a little unorthodox. I tried at the beginning to use the latest nvidia driver from the web, but it did not play nice with me. Eventually I reinstalled Ubuntu and installed bumblebee ( ) , which gives optimus support. I follow the tutorial and inside it there were instructions how to install the nvidia driver from repository. It works for me now. One very important thing is not to install the restricted drivers Ubuntu is offering immediately after the installation, because they are not good for CUDA and it is very hard to get rid of them.

Is it Toolkit version 4.1? As far as I understood, to make it work as you need it to work is never easy :smile:

I’ll follow your instructions, thank you!

Have a nice day,


Hi, could you be a bit more specific please? I’m really interested here.

So far I managed to get cuda 4.0 and 4.1 working on my optimus laptop, with the dev driver 285.05.33 (the one coming with cuda 4.1).

However, AFAICT this driver is nowhere proposed on a Ubuntu repository or ppa. The one I currently have is 270.41.06. I don’t think it permits to run neither cuda 4.0 nor cuda 4.1 codes (although it should permit to run cuda 3.2 codes I guess).

So ultimately, whenever I compile a cuda code, I can run it without any trouble since it automatically loads the dev drivers upon starting. I can likewise run video-demanding applications using bumblebee with “optirun” (provided the dev driver has been unloaded from the kernel if ever). But I can’t run graphics+cuda code since only bumblebee gives me access to the NVIDIA card, but only with a unsuitable driver.

So ultimately, the question summarises in: how can I install the dev driver in a way that allows bumblebee to take it into account?

NB: TBH, since I don’t really develop graphics+cuda codes, this issue is far from critical for me, but having a cleaner install would be nice.


I followed the link you gave and installed the ppa for ubuntu-x-swat/x-updates. I gave me access to driver version 295.20 that do work with cuda 4.1. Now, I can run the nbody example with otirun! So my problem is solved. Cool! I’ll uninstall the 285.05.33 dv driver since I don’t need it any more.



If you manage to install bumblebee you can proceed yo install cudatoolkit. You have to use optirun ./cuda_program to run your examples. The compiling will work just as normal.

ok thank you!

but just one thing, I read there has been problems with compatibility with latest CUDA Toolkit, did you install Toolkit 4.x or the 3.x?

This makes the difference for me.


Yes I use 4.1. (I thought that I wrote that tin my previous post, but I see now that I did not.) Also Gilles_C just confirmed that he updated from 4.0 to 4.1. I have a Acer 4830tg.