CUDA Made the Computer Screen Flashing ??

My computer configuration :
Tesla k40c and Quadro 400
flash disk 128G and hard disk 2T,
operating systerm Ubuntu 14.04,
CUDA-6.5.14,NVIDIA driver 340.32

Sorry for my poor English.
I installed the operating systerm in the flash disk.I installed the CUDA in this way: firstly,I put the Nouveau into the blacklist,secondly I installed the NVIDIA driver,then I installed the CUDA but choose the driver no.I could not forget to add the PATH and LD_LIBRARY_PATH in the bashrc.It seemed that operating systerm started to become unstable after I installed CUDA,some flash appeared occasionally.Then I downloaded some libraries to make the CUDA samples and restart my computer,this time the GUI disappeared,then I reinstalled the driver according to the CUDA manual,GUI recovered.
The content in CUDA manual:
[If the target system includes both an integrated GPU (iGPU) and a discrete GPU
(dGPU), the --no-opengl-libs option must be used. Otherwise, the openGL library used
by the graphics driver of the iGPU will be overwritten and the GUI will not work. In
addition, the xorg.conf update at the end of the installation must be declined.
Installing Mesa may overwrite the /usr/lib/libGL.so that was previously installed
by the NVIDIA driver, so a reinstallation of the NVIDIA driver might be required after
installing these libraries.]

I run ./devicequery in cuda samples and it could detect two device and CUDA run ok in my caffe experiments,but the computer screen flash does not diappear.
The worst moment was the mouse hitting on the firefox browser frame when the window linked to a web adddress hardly because of the network speed or I tried to modify the file like bashrc in the ubuntu.
I have no idea about this problem and I worry about whether it would deteriorate in the future.Does it have something with the conflict between ubuntu 14.04 and CUDA or the different property of the two GPU or the electromagnetic interference between hardwares or any other possibilities??
Help me please ~~ thanks a lot.

It might still be a nouveau issue. Blacklisting nouveau may not be enough, if the nouveau driver is still present in your init ramdisk image. Maybe take a look at this thread:

https://devtalk.nvidia.com/default/topic/789018/cuda-setup-and-installation/problem-installing-cuda-ubuntu-14-04-lts/

Do you get a flashing screen where it flashes several times quickly? I had this issue and it went away once I installed a newer NVIDIA driver (I have 340.58 right now).

I am very grateful for your reply and I will try.

Yes,it is! I will try.Thank you very much. ^^

I did disable nouveau and tried NVIDIA driver 340.58 , the os seems a little bit more stable,but this issue does not disappear and the computer screen still flashes several times quickly.Are there any reports about the compatibility between CUDA and Ubuntu 14.04??I am anxious about this issue.


cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module 340.58 Fri Oct 31 17:40:28 PDT 2014
GCC version: gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1)


I think I am having the same or a similar problem on two systems that I use as a small development cluster. Both are recently upgraded to Ubuntu 14.04 server 64-bit, with GTX 465 on AMD CPUs. CUDA 6.5 results in flashing windows, borders, or content within applications (i.e. nsight, firefox, and even terminal window flashing between current and previous window contents, roll-ups also flash up and down in nsight project explorer). Is that the kind of flashing that others are seeing?

I did the package manager install. Have now done it several times, starting out with a clean install of Ubuntu server with no GUI. Same result if I let CUDA install the desktop, or if I install the desktop environment manually. I use server and then install the desktop after the fact because I run RAID disks, and Ubuntu seems to have taken RAID out of desktop install.

Everything compiles and runs, it just seems like a really unstable UI environment, and the flashing can get so bad as to make it impossible to do any real work.


cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module 340.29 Thu Jul 31 20:23:19 PDT 2014
GCC version: gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1)


I have the same OS and CUDA installed on a third system, a laptop, and that is fine and shows non of the same behavior, but it is running different nvidia h/w and Intel CPU.

I will try 340.58 too and let you know if I see any difference on my systems. I am also very interested in fixing the UI stability in 14.04 with cuda.

Found a workaround to my type of flashing, not sure if it is the same as yours. It appears to be a bug between nvidia drivers and the compiz layer in the ubuntu desktop stack for 14.04. It is just what it looks like on my system, a bug with improper buffer swapping. I am able to get this fix to work using the current package manager version of the driver (340.29).

Full dialog on the bug is here:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1314367

Workaround: install compiz configuration settings manager, run ccsm tool, scroll down and select “Workarounds”, then check the enable box for “Force full screen redraws (buffer swap) on repaint”.

This completely eliminated this problem for me. I’m chasing down some other issues when CUDA 6.5 is installed on one of my Ubuntu 14.04 systems, but at least two out of the three systems are now functioning stable and I can get on with code development.

The flashing disappeared after I just changed from ubuntu desktop into kubuntu desktop.Maybe it is the bug between the nvidia drivers and ubuntu desktop ,but in my option, it also has something with the hardware environments,because not everyone encounts this problem. The compatibility of ubuntu os and nvidia drivers should be improved.
Thank you for your great help!
(Sorry for that I am not familiar with computer programming and cannot figure the bug you pointed out totally. )

I can confirm that the workaround forwarded by Shartung and involving CCSM worked pretty well and fast. I spent ages trying to get over this problem and tried this suggestion out just as I was about to go back to 12.04 and using CUDA Toolkit 6.0. I have two cards: a Tesla K20c and a Quadro 2000.

hi I am so excited to say that the approach raised by shartung does work!!
And I am so happy to see the problem be solved after bothering me for so long time

I applied shartung’s solution as well. Let’s hope that it doesn’t load the system, as the tooltip for that setting mentions the CPU and GPU load increase.