CUDA on [Non-supported] distros?

Has anybody out there gotten CUDA to work on anything other than the officially supported Red Hat Distro? I’m about to start seeing what’s-what on Gentoo.

On Gentoo, I get the following compile errors:

Which continue on.

It looks like __GLXextFuncPtr is not defined in the glxext.h that NVIDIA ships with CUDA, although it is in mine.

#ifndef GLX_ARB_get_proc_address

typedef void (*__GLXextFuncPtr)(void);


whereas the NVIDIA header just seems to assume it’s defined already, although I don’t see any includes that would declare it before the usage. (All the includes are stdint.h and other standard platform includes.)

#ifndef GLX_VERSION_1_4

#define GLX_VERSION_1_4 1


extern __GLXextFuncPtr glXGetProcAddress (const GLubyte *);


typedef __GLXextFuncPtr ( * PFNGLXGETPROCADDRESSPROC) (const GLubyte *procName);


Hmmm… Do I dare just copy-and-paste it in?

I just went to give the copy-and-paste a try and found this in …/…/common/inc/glxext.h:

#ifndef GLX_ARB_get_proc_address


 * Linux OpenGL ABI specifies glXGetProcAddressARB should be

 * in glx.h moving related defines there as well.



But NVIDIA doesn’t supply a glx.h, so my Gentoo version (which has it in /usr/include/GL/glxext.h) won’t be found since it’s being replaced by the NVIDIA version…

Worked straight out of the box on my gentoo system…

Unfortunately we aren’t able to officially support linux systems other than RedHat Enterprise Linux 4 update 3. This means that if you report a bug we can’t currently investigate it. This is because we have chosen to support a small number of OSes for the beta so we can focus on fixing major issues and improving performance.

That said, others have had good success using CUDA on other Linuxes. The ones I’ve heard about include Fedora Core 5, SuSE, and Ubuntu, and now Gentoo from cdyken.

Philippe23: is it possible that your NVIDIA display driver installation did not complete successfully? Have you checked the install log for any errors or warnings?

(I’m not an expert on our Linux display drivers, so I’m just guessing, here.)



I have CUDA 0.8 working on SuSE 10.0 and 10.2 distributions using the system GCC (versions 4.0 and 4.2pre) and the special Linux driver provided for CUDA. The only thing I had to do was adding the X11 includes and libs to the SDK samples for the OpenGL samples as on SuSE it does not find them automatically.


I’m using CUDA on Debian. The only thing I need is a gcc/g++ 3.4. It works pretty well.

As noted by Mark, CUDA does work perfectly well on ubuntu. We had some minor issues with the distro kernel module constantly overwriting the installed one, but that went away with an upgrade to the latest ubuntu version (edgy).


I also confirm CUDA working fine on (k)ubuntu edgy. Nothing special to do to build and run.

That’s slightly out-of-topic, but what about Solaris 10?

  1. Does someone have a feeling of the amount of work needed to make the current Linux Cuda work under Solaris 10 (I lack experience with Linux, so I have no idea if we’re speaking of days, weeks or months)?

  2. Is there, in the future (either middle-term or long-term) anything indicating that Cuda will be supported with Solaris?

Thank you for any element of answer you can bring. :)

Sorry, I don’t actually have an 8800 card yet, so I’m just messing about when I have free time.

On that same note, I didn’t install the 8800 nVidia drivers since I don’t have a 8800. I didn’t think it was necessary per Simon Green’s statement in another thread:

Is that only true on Windows (not Linux)?

Just to confirm: CUDA also works with a fresh suse 10.2 installation without updates.

I can confirm it works on Ubuntu Feisty. Also, while they say they won’t officially support it on anything RedHat, I know that it should be guaranteed to work on Debian Etch at least until mid-May due to:

Hi all,

Im having some issues on ubuntu: can anybody give me a hint?



felix@mue-11:~/NVIDIA_CUDA_SDK$ sudo make emu=1

make[1]: Betrete Verzeichnis ‘/home/felix/NVIDIA_CUDA_SDK/common’

ar qv ./…/lib/libcutil.a ./…/bin/obj/release/bank_checker.cpp_o ./…/bin/obj/release/cmd_arg_reader.cpp_o ./…/bin/obj/release/cutil.cpp_o ./…/bin/obj/release/error_checker.cpp_o ./…/bin/obj/release/stopwatch.cpp_o ./…/bin/obj/release/stopwatch_linux.cpp_o

a - ./…/bin/obj/release/bank_checker.cpp_o

a - ./…/bin/obj/release/cmd_arg_reader.cpp_o

a - ./…/bin/obj/release/cutil.cpp_o

a - ./…/bin/obj/release/error_checker.cpp_o

a - ./…/bin/obj/release/stopwatch.cpp_o

a - ./…/bin/obj/release/stopwatch_linux.cpp_o

make[1]: Verlasse Verzeichnis ‘/home/felix/NVIDIA_CUDA_SDK/common’

make -C projects/bitonic/

make[1]: Betrete Verzeichnis ‘/home/felix/NVIDIA_CUDA_SDK/projects/bitonic’

g++ -m32 -fPIC -o …/…/bin/linux32/emurelease/bitonic …/…/bin/obj/emurelease/bitonic.cu_o -L/usr/local/cuda/lib -L…/…/lib -lcuda -lcudart -lGL -lGLU -l cutil

/usr/bin/ld: warning:, needed by /usr/local/cuda/lib/, not found (try using -rpath or -rpath-link)

/usr/local/cuda/lib/ undefined reference to `fatSetLogLine’

/usr/local/cuda/lib/ undefined reference to `fatGetCubinForGpu’

collect2: ld returned 1 exit status

make[1]: *** […/…/bin/linux32/emurelease/bitonic] Fehler 1

make[1]: Verlasse Verzeichnis ‘/home/felix/NVIDIA_CUDA_SDK/projects/bitonic’

make: *** [projects/bitonic/Makefile.ph_build] Fehler 2


It works on the current Fedora 6 distribution. The SDK needs the already reported fix to matrixmul_drv.cpp to pass the distributed g++ and the scan_largearray example reports that the test has failed. Otherwise, seems fine.

The current Fedora rawhide is based on a beta Xorg server and is not worth testing.

It looks like /usr/local/cuda/lib/ from the cuda distribution has been deleted as the linker can not find it despite being given the location on the g++ command line.

no is in /usr/local/cuda/lib
Any suggestions anyone?


You forgot to set your LD_LIBRARY_PATH to include the CUDA dir.


export LD_LIBRARY_PATH=/usr/local/cuda/lib:$LD_LIBRARY_PATH

in your log:

/usr/bin/ld: warning:, needed by /usr/local/cuda/lib/, not found (try using -rpath or -rpath-link)

Someone already replied, yeah, How to delete a post? :lol:

Obviously, avoid the Xen kernels. I also disabled SELinux. As per the docs, you’ll need to install openGLUT. But aside from that, FC 6 with a current ‘yum update’ works just fine.