cudaErrorUnknown 999 when calling cudaGraphicsGLRegisterBuffer

Hi everyone,

Installed Cuda 10.2.89 extracting the runfile on this laptop:

  • Dell Inspiron 7559
  • Intel® Core™ i7-6700HQ CPU @ 2.60GHz
  • GeForce GTX 960M [compute capability 5.0]
  • OpenSUSE Leap 15.0, kernel 4.12.14-lp150.12.73-default
  • driver Nvidia-G05 440.44-lp150.22.1 (installed from the package manager in YaST)

All cuda-samples were successfully compiled, but those requiring nvscibuf.h (but this is not the problem).

When running the sample “nbody” in folder “5_Simulations”, I encountered this error:

CUDA error at bodysystemcuda_impl.h:183 code=999(cudaErrorUnknown) “cudaGraphicsGLRegisterBuffer(&m_pGRes[i], m_pbo[i], cudaGraphicsMapFlagsNone)”

Tried many times to reinstall driver and Cuda in many different ways, however I keep encountering that error.
I also tried to run nbody with -benchmark option (and therefore without visualization) and it works fine.
Running nbody setting the -cpu option works fine as well even without the -benchmark option (the bodies are rendered).

I read that the reason may be that, when dealing with laptops in linux, displaying using Nvidia graphics can be troublesome.
Is there a way to render the colliding bodies using the integrated gpu while computing on the dedicated Nvidia gpu?
Sorry if my question is trivial or badly asked, I’m just approaching gpu computing and Cuda, and everything is new to me.

In case that in the previous paragraph I was wrong, any help to solve the cudaErrorUnknown shown previously would be much appreciated.
Please, ask me everything it’s needed to understand what’s happening and if there’s a solution.

Thanks

I am having the same issue but on a server with 4 x Tesla T4 cards… the screen is plugged into the onboard graphics port as T4 has no output.
Benchmark seems to work but none of it works when a graphical output is needed.

Have u figured out the problem as I am also getting the same error