Custom sensor driver - getting striped image


Our team is trying to develop a custom sensor driver for OS08A20 from OmniVision, to make it work with the Jetson Nano on the Developer Kit B01 board.

We can finally get an output stream from the sensor using gst-launch-1.0 and v4l2-ctl. However, what we get is a “striped” image like in the image below.

Anyone know what the problem might be? We have checked the register values on the mode tables, and it seems fine, and have also tried tweaking the parameters in the device tree, but nothing makes it behave differently.
test-000.pnm (5.9 MB)

We do not have much experience in driver development, so if you could help us out it would be incredible! Thanks!

What’s APP to open the .pnm?
Did you check the raw image from v4l2-ctl?

1 Like

Hi! We have already solved our problem. It was wrong values on some registers and the pixel_clk_hz and line_length fields on the device tree. Now we have normal video! Thanks!

Hello again! I need your help once again. I am using a Jetson Nano with the DevKit Carrier Board B01. Up until now, I was using a clock source from a signal generator, at 24MHz. Now, I would like to change this and use the Jetson as the sensor’s clock source, also at 24MHz, on Cam1 CSI port (cam-i2cmux 8). I know I need to add it to my device-tree, but I have no idea how. Can you help me with that?


Reference to …/hardware/nvidia/platform/t210/jetson/kernel-dts/jetson-platforms/tegra210-jetson-cv-camera-e3326-a00.dtsi to add below to your dts.

				clocks = <&tegra_car TEGRA210_CLK_CLK_OUT_3>;
35 				clock-names = "clk_out_3";
36 				clock-frequency = <24000000>;
38 				mclk = "clk_out_3";
1 Like

Thank you for your quick reply. Will this work for both CSI ports (Cam0 and Cam1) of the devkit board?

Because at the time, I can only use the Cam1 port (cam-I2Cmux @ port 8) to connect the camera to, and I have tried something like this and could not make it work!

Yes, it work for all CSI port.

1 Like

Ok! Thank you very much! Will try this again!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.