Dataset_convert tool is running properly but the TFrecords aren't getting created in output folder

Please provide the following information when requesting support.

• Hardware (T4/V100/Xavier/Nano/etc) - GeForce MX450
• Network Type YOLO_V4

Hello,
unable to create output file although the prompt shows that the TFrecords are being created.
Can you please help?

Usually this kind of issue is due to wrong setting in ~/.tao_mounts.json.
See TAO Toolkit Launcher — TAO Toolkit 3.22.02 documentation

BTW, for debug use, you can login the docker directly as below and check the tfrecord files.
$ tao yolov4 run /bin/bash
# ls xxx

Felt like I fixed the above error but now getting the following error

Docker instantiation failed with error: 400 Client Error: Bad Request (“failed to create shim: OCI runtime create failed: container_linux.go:380: starting container process caused: process_linux.go:545: container init caused: Running hook #0:: error running hook: exit status 1, stdout: , stderr: nvidia-container-cli: initialization error: load library failed: /usr/lib/wsl/drivers/nvam.inf_amd64_61df758291bf519e/libnvidia-ml.so.1: cannot open shared object file: no such file or directory: unknown”)

When is the “Mapping up the local directories to the TAO docker” happening?(as mentioned in the ~/.tao_mounts.json file? is there a problem with the directory path in the above problem?

This is the code I am trying to execute -

!tao yolo_v4 dataset_convert -d $SPECS_DIR/yolo_v4_tfrecords_kitti_train.txt
-o $DATA_DOWNLOAD_DIR/training/tfrecords/train

Can you share the full command when you meet above error?

Here is the command -

!tao yolo_v4 dataset_convert -d $SPECS_DIR/yolo_v4_tfrecords_kitti_train.txt
-o $DATA_DOWNLOAD_DIR/training/tfrecords/train

Is there any issue with the SPECS_DIR variable?

Please check if Tao speech_to_text evaluate+infer show very weak results - #23 by user138800 helps.

When I run command -

nvidia-container-cli --loads-kmods info

I get the following error -

nvidia-container-cli: initialization error: load library failed: /usr/lib/wsl/drivers/nvam.inf_amd64_61df758291bf519e/libnvidia-ml.so.1: cannot open shared object file: no such file or directory

I installed all the libraries as mentioned in the post and restarted the system but it is still showing the same error.

You are running with WSL. I am afraid it is not an issue from TAO.
Please google something and find help there.
For example, Nvidia driver not detected on WSL2 · Issue #1604 · NVIDIA/nvidia-docker · GitHub

For this error, please try to run below.

$ apt-cache search nvidia-driver
$ sudo apt install nvidia-driver-470

I found this solution online -
But I can’t understand what is my image -

doesn’t seem to work

Did you retry after installing the nvidia-driver?

yes! but it is showing the same error

As mentioned here, the missing file seems to be in the respective folder…

Can you share the log? Seems that you already delete it.

Share the log for which command?..

For above comment.