DeepStream 5.0 Example Run Errors

Please provide complete information as applicable to your setup.

Today I have followed the doc:
https://docs.nvidia.com/metropolis/deepstream/dev-guide/text/DS_Quickstart.html#dgpu-setup-for-ubuntu.

After I have installed TensorRT7.0, cuDNN7.6 with CUDA-10.2, I can run 2 examples successfully:

A. the location I have run: /opt/nvidia/deepstream/deepstream-5.0/samples/configs/deepstream-app

B. the two examples I have run:
source1_usb_dec_infer_resnet_int8.txt
source30_1080p_dec_infer-resnet_tiled_display_int8.txt

C. two examples run with ERRORs:
source30_1080p_dec_infer-resnet_tiled_display_int8.txt with error:
** ERROR: main:655: Failed to set pipeline to PAUSED
Quitting
ERROR from src_bin_muxer: Output width not set
Debug info: gstnvstreammux.c(2283): gst_nvstreammux_change_state (): /GstPipeline:pipeline/GstBin:multi_src_bin/GstNvStreamMux:src_bin_muxer
App run failed

config_mux_source4.txt with errors:

** ERROR: <parse_config_file:320>: Source group “[source-config-0]” is not in the form “[source<%d>]”
** ERROR: <parse_config_file:513>: parse_config_file failed
** ERROR: main:627: Failed to parse config file ‘/opt/nvidia/deepstream/deepstream-5.0/samples/configs/deepstream-app/config_mux_source4.txt’
Quitting
App run failed

**• Hardware Platform: dGPU laptop with RTX2080
**• DeepStream Version: 5.0
• JetPack Version (valid for Jetson only) – N/A
• TensorRT Version – 7.0
**• NVIDIA GPU Driver Version: 450.80.02

Can you suggest a way to solve those problem?
Thanks
Jimmy

See inline.

@amycao, thanks for your response.

  1. config_mux_source4.txt
    After I have changed [source-config-0] into: [source0], now I get the new error:

** ERROR: main:655: Failed to set pipeline to PAUSED
Quitting
ERROR from src_bin_muxer: Output width not set
Debug info: gstnvstreammux.c(2283): gst_nvstreammux_change_state (): /GstPipeline:pipeline/GstBin:multi_src_bin/GstNvStreamMux:src_bin_muxer
App run failed

  1. Actually the source30_1080p_dec_infer-resnet_tiled_display_int8.txt run fine for me. Rather the
    source4_1080p_dec_infer-resnet_tracker_sgie_tiled_display_int8_gpu1.txt shows the ERROR:

Unable to set device in gst_nvstreammux_change_state
Unable to set device in gst_nvstreammux_change_state
Unable to set device in gst_nvstreammux_change_state
** ERROR: main:655: Failed to set pipeline to PAUSED
Quitting
Unable to set device in gst_nvstreammux_change_state
App run failed

Here is the config file for config_mux_source4.txt as example

[property]
algorithm-type=1
batch-size=4
#max-fps-control disables (=0) and enables (=1)
#throttling of buffers in muxer to roughly achieve
#confligured max-fps setting
max-fps-control=0
overall-max-fps-n=40
overall-max-fps-d=1
overall-min-fps-n=5
overall-min-fps-d=1
max-same-source-frames=1

[source0]

Numerator of this source’s max frame rate fps_n/fps_d; uint

max-fps-n=30

Denominator of this source’s max frame rate fps_n/fps_d; uint

max-fps-d=1

Numerator of this source’s min frame rate fps_n/fps_d; uint

min-fps-n=5

Denominator of this source’s min frame rate fps_n/fps_d; uint

min-fps-d=1

Priority of this source; unsigned-int

priority=0

Max number of frames allowed to be muxed per output batch buffer; uint

max-num-frames-per-batch=1

[source1]

Numerator of this source’s max frame rate fps_n/fps_d; uint

max-fps-n=120

Denominator of this source’s max frame rate fps_n/fps_d; uint

max-fps-d=1

Numerator of this source’s min frame rate fps_n/fps_d; uint

min-fps-n=5

Denominator of this source’s min frame rate fps_n/fps_d; uint

min-fps-d=1

Priority of this source; unsigned-int

priority=0
max-num-frames-per-batch=1

[source2]

Numerator of this source’s max frame rate fps_n/fps_d; uint

max-fps-n=120

Denominator of this source’s max frame rate fps_n/fps_d; uint

max-fps-d=1

Numerator of this source’s min frame rate fps_n/fps_d; uint

min-fps-n=5

Denominator of this source’s min frame rate fps_n/fps_d; uint

min-fps-d=1

Priority of this source; unsigned-int

priority=0
max-num-frames-per-batch=1

[source3]

Numerator of this source’s max frame rate fps_n/fps_d; uint

max-fps-n=120

Denominator of this source’s max frame rate fps_n/fps_d; uint

max-fps-d=1

Numerator of this source’s min frame rate fps_n/fps_d; uint

min-fps-n=5

Denominator of this source’s min frame rate fps_n/fps_d; uint

min-fps-d=1

Priority of this source; unsigned-int

priority=0
max-num-frames-per-batch=1

[quote=“jqin2014m7df9, post:4, topic:164637”]

  1. config_mux_source4.txt
    After I have changed [source-config-0] into: [source0], now I get the new error:

** ERROR: main:655: Failed to set pipeline to PAUSED
Quitting
ERROR from src_bin_muxer: Output width not set
Debug info: gstnvstreammux.c(2283): gst_nvstreammux_change_state (): /GstPipeline:pipeline/GstBin:multi_src_bin/GstNvStreamMux:src_bin_muxer
App run failed

  1. Now after I change the gpu-id=1 into gpu-id=0 (since I only have one gpu, now
    source4_1080p_dec_infer-resnet_tracker_sgie_tiled_display_int8_gpu1.txt runs ok

Glad to know.

Any suggestions how to solve following error when run test: config_mux_source4.txt
After I have changed [source-config-0] into: [source0], now I get the new error:

** ERROR: main:655: Failed to set pipeline to PAUSED
Quitting
ERROR from src_bin_muxer: Output width not set
Debug info: gstnvstreammux.c(2283): gst_nvstreammux_change_state (): /GstPipeline:pipeline/GstBin:multi_src_bin/GstNvStreamMux:src_bin_muxer
App run failed

oh, i thought you fixed it, but this config, config_mux_source4.txt, you still have issue, right? how about gpu-id set in this config?

@amycao, for this config_mux_source4.txt, there is no gpu-id inside. Following is the contents:

[property]
algorithm-type=1
batch-size=4
#max-fps-control disables (=0) and enables (=1)
#throttling of buffers in muxer to roughly achieve
#confligured max-fps setting
max-fps-control=0
overall-max-fps-n=40
overall-max-fps-d=1
overall-min-fps-n=5
overall-min-fps-d=1
max-same-source-frames=1

[source0]

Numerator of this source’s max frame rate fps_n/fps_d; uint

max-fps-n=30

Denominator of this source’s max frame rate fps_n/fps_d; uint

max-fps-d=1

Numerator of this source’s min frame rate fps_n/fps_d; uint

min-fps-n=5

Denominator of this source’s min frame rate fps_n/fps_d; uint

min-fps-d=1

Priority of this source; unsigned-int

priority=0

Max number of frames allowed to be muxed per output batch buffer; uint

max-num-frames-per-batch=1

[source1]

Numerator of this source’s max frame rate fps_n/fps_d; uint

max-fps-n=120

Denominator of this source’s max frame rate fps_n/fps_d; uint

max-fps-d=1

Numerator of this source’s min frame rate fps_n/fps_d; uint

min-fps-n=5

Denominator of this source’s min frame rate fps_n/fps_d; uint

min-fps-d=1

Priority of this source; unsigned-int

priority=0
max-num-frames-per-batch=1

[source2]

Numerator of this source’s max frame rate fps_n/fps_d; uint

max-fps-n=120

Denominator of this source’s max frame rate fps_n/fps_d; uint

max-fps-d=1

Numerator of this source’s min frame rate fps_n/fps_d; uint

min-fps-n=5

Denominator of this source’s min frame rate fps_n/fps_d; uint

min-fps-d=1

Priority of this source; unsigned-int

priority=0
max-num-frames-per-batch=1

[source3]

Numerator of this source’s max frame rate fps_n/fps_d; uint

max-fps-n=120

Denominator of this source’s max frame rate fps_n/fps_d; uint

max-fps-d=1

Numerator of this source’s min frame rate fps_n/fps_d; uint

min-fps-n=5

Denominator of this source’s min frame rate fps_n/fps_d; uint

min-fps-d=1

Priority of this source; unsigned-int

priority=0
max-num-frames-per-batch=1

Can you share the whole file and attached as file?

Can you let me know I can attached the .tar file since I cannot figure it out? The share icon only let me share a URL link? thanks

in the edit window, there one upload icon to choose to upload file.

@amycao, I have attached: config_mux_source4.txt.

  1. run command: deepstream-app -c config_mux_source4.txt

  2. error message:

** ERROR: main:655: Failed to set pipeline to PAUSED
Quitting
ERROR from src_bin_muxer: Output width not set
Debug info: gstnvstreammux.c(2283): gst_nvstreammux_change_state (): /GstPipeline:pipeline/GstBin:multi_src_bin/GstNvStreamMux:src_bin_muxer
App run failed
config_mux_source4.txt (3.2 KB)

The config file is not correct, please refer to any config file source***under samples/configs/deepstream-app to pass as deepstream-app option -c config file.