Deepstream 6.0 & 6.1 not working with drivers 510.85.02

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) GPU
• DeepStream Version 6.1 - Docker container 6.1-devel
• JetPack Version (valid for Jetson only)
• TensorRT Version default in Docker container 6.1-devel
• NVIDIA GPU Driver Version (valid for GPU only) 510.85.02

I can’t manage to run any code regarding deepstream. I’ve updated the drivers from 470.141.03 to 510.85.02 and now nothing runs.

Previously I had cuda 11.4 and now cuda 11.6.

Before I also had deepstream 6.0 with drivers 470.141.03 and when I’ve updated the drivers the code in this version stopped working. After this I updated the docker image to to try and the same thing happened.

Not even the samples from /opt/nvidia/deepstream/deepstream-6.1/samples work. It’s not a matter of code, but environment. Because the code is absolutely the same, I’ve just updated the drivers.

The error that I have is the following:

gst-stream-error-quark: Internal data stream error. (1): qtdemux.c(6073): gst_qtdemux_loop (): /GstPipeline:pipeline0/GstBin:source-bin-00/GstURIDecodeBin:uri-decode-bin/GstDecodeBin:decodebin0/GstQTDemux:qtdemux0:
service    | streaming stopped, reason not-linked (-1)

Which app you are running into the error?

Regarding the NVIDIA examples,

When running this command:

cd /opt/nvidia/deepstream/deepstream-6.1/samples/configs/deepstream-app
deepstream-app -c source30_1080p_dec_infer-resnet_tiled_display_int8.txt

The error is the following:

** ERROR: <main:716>: Failed to set pipeline to PAUSED
App run failed

Which GPU you are using?

I am using NVIDIA GPU: RTX 3090

If you have monitor connected to the server, you can export DISPLAY environment from remote ssh terminal, by export DISPLAY=:0 you also can choose save to file by choose sink type file. or streaming by rtsp, choose sink type 4. view the output by vlc.

That doesn’t seem to change the outcome. Still getting the same error that I showed before. The server is a remote machine connected with ssh without display. To see the outcome I just copy the file to my PC with ssh.

I’m running deepstream in Docker. Maybe there is a different step with this environment?

Updated to drivers 515.65.01 and same error on both versions of deepstream: 6.0.1 & 6.1

If you do not have monitor connected, export DISPLAY is useless. please try other options mentioned in comment 6.

I don’t understand your suggestion. Are you saying that the code in the NVIDIA example is not correct and so I have to edit the pipeline? I’m running the defaults examples from the container and even then they do not work.

This is the command that I am running:

cd /opt/nvidia/deepstream/deepstream-6.1/samples/configs/deepstream-app
deepstream-app -c source30_1080p_dec_infer-resnet_tiled_display_int8.txt

I want to know if my driver version is correct or it has to be exact as the version specified. My version is newer than the specified and NVIDIA drivers have backward compatibility, so I don’t know why It would be a problem.

Just to be clear. We have the same code on two different machines.

One with drivers: 470.141.03 → Everything works fine in deepstream 6.0.1
Other with drivers: 510.85.02 → Nothing works, neither deepstream 6.0.1 nor deepstream 6.1. Not even the examples provided by the deepstream container

There is no update from you for a period, assuming this is not an issue anymore.
Hence we are closing this topic. If need further support, please open a new one.

If you use nveglglessink, and have no monitor connected, export DISPLAY is useless from remote terminal. that’s why i suggest you if this case, you can try other sink type like fakesink file or rtspstreaming.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.