Deepstream 6.0 deepstream-app make error

hi
when I build deepstream-app:
make have Perhaps you should add the directory containing `json-glib-1.0.pc’ error
use Jetpack 4.4 install libjson-glib-dev fail mothed install sudo dpkg -i libjson-glib-dev_1.4.2-3ubuntu0.18.04.1_arm64.deb
then make it have fatal error: gst/rtsp-server/rtsp-server.h: No such file or directory
#include <gst/rtsp-server/rtsp-server.h>
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
error
then I install libgstrtspserver-1.0-dev but have The following packages have unmet dependencies:
libgstrtspserver-1.0-dev : Depends: libgstrtspserver-1.0-0 (= 1.14.0-1) but 1.14.5-0ubuntu1~18.04.1 is to be installed
E: Unable to correct problems, you have held broken packages. error
plealse help
jetson 4.6 deepstream 6.0

from the logs, need to install libgstrtspserver , please refer to Quickstart Guide — DeepStream 6.0.1 Release documentation
please refer to deepstream-app’s README file,need to install some packages.

I use deepstream-app’s README file mothed to install package.


when

sudo apt-get install libgstrtspserver-1.0-dev

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgstrtspserver-1.0-dev : Depends: libgstrtspserver-1.0-0 (= 1.14.0-1) but 1.14.5-0ubuntu1~18.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.

please help

seemed there is lib depencies issue.
1 execute dpkg -l |grep rtsp , and show your result.
2 try this sudo apt-get -f install libgstrtspserver-1.0-dev
3 if can’t fix, try “sudo apt-get remove libgstrtspserver-1.0-0” , then “sudo apt-get install libgstrtspserver-1.0-0 libgstrtspserver-1.0-dev”