Deepstream 6.0 Yolo cannot save .mp4 output video

• Hardware Platform (Jetson / GPU) Jetson Xavier NX
• DeepStream Version 6.0
• JetPack Version (valid for Jetson only) 4.6
• TensorRT Version 8.0.1-1

Hi I’m trying to save .mp4 output when using yolo.
It seems to save output video well when I run it for a minute.
But when I run it for a day, the stored video does not work and shows ‘This file contains no playable streams’.

I used yolov3 for the test :

/opt/nvidia/deepstream/deepstream-6.0/sources/objectDetector_Yolo/deepstream_app_config_yoloV3.txt

and only added sink 1 and sink 2 as below for video saving and RTSP streaming:

I used this code for the test:

sudo deepstream-app -c deepstream_app_config_yoloV3.txt

I am not sure why the video shows an error when I run it for long time.
Thanks for your help and please let me know if other info is needed

From the configuration, you used rtsp streaming, but file saving disabled? did you put the wrong properties or you use othe method to save the output? and did you notice whe you run for more than one day, the storage remaining of the device? and which input source you used?

Sorry! both of rtsp streaming and file saving was enabled.
I used 1TB ssd for storage so i think storage does not matter.
For the input source, I used two IP cameras and checked both of them works well

How about change file sink encoder type to software?

Nope… it doenst work at all if i change the type to software.

When the issue happened, did you quit gracefully? for deepstream-app, you can enter q to quit the app.

yes i always use q to quit the app…

from your screenshot, the video output sink is not enabled.
If it’s enabled, please refer to “4.1 deepstream-app” section in DeepStream SDK FAQ - #10 by mchi to capture the GStreamer Pipeline Graph and sahre with us.

image

Hi mchi
the sink was enabled.
I tried to use ‘dot -Tpng’ to change dot file to png.
However there was two playing,dot file and i was not sure which file i should use.
so I converted both of them.
please let me know if you need any other file.

dotToPng.zip (2.5 MB)

@mchi hi, is there any progress or something found from the png file??

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

Sorry! The 2nd image is too blur.
Could you share the detailed repo files and steps based on
/opt/nvidia/deepstream/deepstream-6.0/sources/objectDetector_Yolo/deepstream_app_config_yoloV3.txt ?