Not able to save output video in deepstream 6.0.1

I’m trying to run a YOLOR model inside Deepstream 6.0.1 on an ubuntu machine. The models run successfully on the input video but the output video(.mp4) is not getting saved. I’ve attached below the screenshots that show what my sinks look like.

1 Like

Here is the screenshot for [sink0]

Can you set output-file without “file://” and retest? There is an example in DeepStream Reference Application - deepstream-app — DeepStream 6.1.1 Release documentation

I tried saving the output video in the following paths, but still, the video is not getting saved.

Please set container to 1 or 2


I’ve tried with both the containers, still, the video is not getting saved.

You have two sink2, please remove one and try again.

Nope, I have only one sink2. Those are two different screenshots with different container ids.

How about set codec to 1 or 2?

Tried with codec too, didn’t work out. I think it’s a bug in Deepstream 6.0.1. Can you provide any patch for the same?

Which GPU you are running on?


There is no update from you for a period, assuming this is not an issue anymore.
Hence we are closing this topic. If need further support, please open a new one.

Change type to 3 in sink2, 1 is for fakesink. and disable sink0

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.