Deepstream apps running extremely slow

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) - Nano
• DeepStream Version - 6.1
• JetPack Version (valid for Jetson only)- 5.0
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

I’ve been trying to run the sample python deepstream apps on my jetson nano 2gb but the speed is extremely slow. At first, I thought it was due to vnc but after recording the screen I realized that the apps were running slow. I am not even getting 6 fps while running the deepstream_test_2.py on a single video and when I increased the featureImgSizeLevel of the tracker to 5 runs 1 frame every 10 seconds (approx). This is happening with all the apps including the sample c++ apps even when I run them on default configurations. Can someone please help solve this? Thanks.

Can you help double check the versions of DeepStream and JetPack? Neither JP5.0 nor DS6.1 supports Nano.

Actually, it’s deepstream 6.0.1 and jetpack 4.6.1 on my Nano. My Xavier NX has deepstream 6.1 so I got confused, my bad.

Please follow this to troubleshoot the app running slowly.
https://docs.nvidia.com/metropolis/deepstream/dev-guide/text/DS_troubleshooting.html#the-deepstream-application-is-running-slowly

Nothing seems to work for me. The only thing that changed was that now it streams all the frames, previously it used to skip frames. But it is still slow.

If nvinfer is the bottleneck, you have to drop frames to increase the running speed.

You can measure the latency of each plugin in the pipeline to determine if one of them is slow.

  • To enable frame latency measurement, run this command on the console:

    $ export NVDS_ENABLE_LATENCY_MEASUREMENT=1

  • To enable latency for all plugins, run this command on the console:

    $ export NVDS_ENABLE_COMPONENT_LATENCY_MEASUREMENT=1

Hello @user76744 Can you let us know if it is still an issue? Anything suspicious from letency measurement? Thanks.

I did run the above command but I’m not sure where to look for an issue. How to identify the issue if any?

Can you paste the log after above environment variables enabled?