Deepstream Triton Docker container cannot run with MPS

Hi All,

Here’s the background. I am trying to run deepstream with Triton inference server in separate docker container (Triton & Deepstream).
The Triton inference server will not be specified to the deepstream application since I am planning to use the inference server in separate use cases. The plan is to use gRPC to communicate between

  1. deepstream application and
  2. Triton inference server

following the tutorial in /opt/nvidia/deepstream/deepstream-6.1/samples/configs/deepstream-app-triton-grpc.

While I am able to run both the server (triton) and the client (deepstream) on the same computer, I would like to utilize the GPU resource by using MPS. (I am assuming the triton image and deepstream image share the GPU resource through context switching/time slicing.)

As long as I enable the MPS, the docker image fail to response and fail to enter into the shell. I tried different containers (as described below) and I am able to run nvidia-smi.

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
GTX 3090
• DeepStream Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)

  1. enable MPS
    export CUDA_MPS_PIPE_DIRECTORY=/tmp/nvidia-mps
    export CUDA_MPS_LOG_DIRECTORY=/tmp/nvidia-log
    sudo nvidia-smi -i 0 -c EXCLUSIVE_PROCESS
    nvidia-cuda-mps-control -d

  2. Run the container docker run --gpus all --ipc=host -it --rm -v /tmp/.X11-unix:/tmp/.X11-unix -e DISPLAY=$DISPLAY --net=host --name=deepstream-client fail

  3. This container works fine docker run --rm --gpus all --ipc=host nvidia-smi ok

Please kindly advise how to use the images with MPS.

Many Thanks!

I will check

how many GPUs on your machine? could you share the terminal log of “Run the container failed”?

I am using only 1 GPU, which is RTX 3090. The terminal just stuck when I run the docker run command without any response.

we tested on local gpu, " docker run --gpus all --ipc=host -it --rm -v /tmp/.X11-unix:/tmp/.X11-unix -e DISPLAY=$DISPLAY --net=host --name=deepstream-client" can be started, but there is an error tip ERROR: No supported GPU(s) detected to run this container , and some deepstream samples test failed with error 805, which means the MPS client failed to connect to the MPS control daemon or the MPS server.
we will continue to investigate.