Deinterlacing problem in TX2

Hi,

We decode the interlaced video with mmapi in TX2,and found that the de-interlacing function is problematic, the output image is rough.

This is the source image.

Thanks!

Please share the video file so that we can reproduce it.

Hi, DaneLLL

Thank you for your response.

Please download the video file in this url.

https://pan.baidu.com/s/1Irj6LHU3XmACaqW3EWHYqg

And run this cmd.

./video_decode deint_test.264 H264 --input-nalu --disable-rendering -o deint_test.yuv

Please also share how to generate source image. Do you use ffmpeg?

Hi, DaneLLL

Play the source file by MPC-HC player (https://mpc-hc.org/).

Hi zcs, we cannot access this link. Can you give a valid link?

Hi, DaneLLL

Please download it here.
http://120.77.3.207/deint_test.264

I am not able to run the command on r28.2.1. Is the command correct?

Hi, DaneLLL

We work at r28.1.0.

Hi, DaneLLL

Is there any progress?

Thanks!

Hi zcs,
We are checking. Do you run clean r28.1? I mean a clean image flashed by Jetpack without any prebuilt libraries being replaced.

Hi, DaneLLL

I had tested it on the clean r28.1, and it look correct.

Hi zcs, do you mean you don’t see the issue on clean r28.1?

Hi, DaneLLL

I mean the command running is correct.

./video_decode deint_test.264 H264 --input-nalu --disable-rendering -o deint_test.yuv

But the output image is also rough.

Please try attachment.
r28_1_libtegrav4l2.zip (60.3 KB)

Hi,DaneLLL

Thank you for the patch.

The output image look correct.

But it cause another issue about the timestamp of video encoder.

https://devtalk.nvidia.com/default/topic/1002773/?comment=5267455

I have updated the attachment at comment #15. Please give it a try.

Hi,DaneLLL

Thank you for the update.