Dell R730 + Grid K1 + Windows 2012 R2 + Hyper Visor, can't enable RemoteFX

Hello, I’m having a problem enabling RemoteFX in Hyper-V manager with above environment.
CPU is Xeon CPU E5-2660 V3@2.60Ghz

  1. I see 4 "Nvidia Grid K1" under Display adapters in Windows "Device Manger", together with "Microsoft Basic Display Adapter". Is this normal?

  2. “Hyper-V Manager” -> “Hyper-V Settings” -> “Physical GPUs”, it’s grayed out and I can’t open the pulldown menu, unless I disable all the 4 Nvidia Grid K1 in Device Manager, and enable all 4 again. Then I can select Grid K1 in “Physical GPUs”. The strange thing is there is only 3 Grid K1 in the Pull down, while there are 4 of them in “Device Manger”. And if I restart the server, then this pulldown becomes gray again and nothing can be selected.

  3. Is there anything I need to enable/disable inside BIOS? I see lots of information over RemoteFX configuration on the web but nothing really did the trick so far.

I have tried 2 different drivers :
Nvidia 9.18.13.47552 and 10.18.13.5382.
With either driver, I face same problem.

Any suggestion & idea welcome.
Thanks in advance,

Ken