Denoise failure with certain resolution (5.1.0)

Hi everyone,

A colleague of mine noticed that the denoiser would fail when processing an image of 2040x3060 resolution. Small variations of ±1px in width/height gave the same result. What happens is that the returned image is black but no error is produced.

Ι was able to reproduce this with the optixDenoiser SDK sample:
–dim 2040x3060 --nopbo --file result.ppm

I ran more tests after adding the “maxmem” variable (same resolution). The image was denoised but only when using values in a certain range. For example on my gpu I got a result when using 2gb or less for maxmem but denoising failed when I increased the value to 2.5. I haven’t noticed this kind of behavior with maxmem occurring with other resolutions.

System Info:
Windows 7 Professional, 64-bit (Service Pack 1)
GeForce GTX 1060 6GB
Driver version: 398.82

I can no longer reproduce this with optixDenoiser on our internal dev branch, and there have been bug fixes along these lines in the denoiser code. Looks like it will be fixed in the next release of OptiX.

Please check this previous report of that bug and a workaround using the denoiser’s “maxmem” variable:
https://devtalk.nvidia.com/default/topic/1036145/?comment=5263840