/dev/watchdog increase timeout

I am running Jetson 4.5 on my NVIDA Xavier XDK and I noticed that the kernel automatic reboot after running some commands. After some investigation and testing and comparing with JetPack 4.3, the reboot happens because the /dev/watchdog did not see any data for ~6 seconds.

Looking at the “demsg”, I can see the WatchDog settings and timeout is set to 6 seconds.

Here is a sample “dmesg” output:

people@peope-x-x-x-x-jetpack-45:~$ dmesg | grep -i watch
[ 0.793390] hw-breakpoint: found 6 breakpoint and 4 watchpoint registers.
[ 0.820355] tegra-pmc: ### PMC reset source: TEGRA_BCCPLEX_WATCHDOG
[ 1.038935] tegra_wdt_t18x 30c0000.watchdog: Expiry count is deprecated
[ 1.039212] tegra_wdt_t18x 30c0000.watchdog: Tegra WDT init timeout = 120 sec
[ 1.039250] tegra_wdt_t18x 30c0000.watchdog: Registered successfully
[ 13.112093] tegra_wdt_t18x 30c0000.watchdog: Watchdog(0): wdt timeout set to 6 sec

How can I increase the timeout without recompile the kernel? Is there a file that I can update to send a parameter on bootup time?

Thanks ahead of time!

Check below doc to implement user space APP to set the timer by ioctl(fd, WDIOC_SETTIMEOUT, &timeout)

Thanks for input! I was curious if there is another way to change the timeout?

I noticed on JetPack 4.3, the timeout was ~60 seconds. However in jetpack 4.5, the timeout is ~6 seconds. What was the reason for the change?

I was hoping there would be a file that I can update and change the timeout settings during bootup. Is there a file?

As I know it 120 seconds no matter j4.3 or j4.5

Thanks ShaneCCC for pointing that out. From my investigation, it was the corosync that was setting to 6 sec. I was able to use the watchdog-simple.c to help with my situation. Thanks you