deviceQuery hang

I just got the cuda SDK3.1 compiled on my ubuntu 10.04 machine and I’m having an issue running deviceQuery. If I run a simple ‘./deviceQuery’ it just sits there and does nothing like it is waiting for something. All of the other programs in ~/NVIDIA_GPU_COMPUTING_SDK/C/bin/linux/release seem to work without issue.

Now if I try and run ‘sudo ./deviceQuery’ or sudo any other device I get:
error while loading shared libraries: cannot open shared object file: No such file or directory

My LD_LIBRARY_PATH is set to /usr/local/cuda/lib64 so I’m not sure why this error comes up. I’m also not sure if deviceQuery needs to be run as sudo.

Any ideas on why it may hang?

I did the following:

sudo bash


and it worked for me.

You shouldn’t have to use sudo at all. Did you install the SDK as a superuser? That’s probably why…

Check the Getting Started guide that NVIDIA provides on the “Get CUDA” webpage. Their advice is to install the CUDA Toolkit as superuser (root) and the SDK in your home directory as yourself. If you install the SDK as superuser, unless you chmod the executables, you won’t be able to execute them without sudo. (Oh, and you won’t be able to run make in the src directories either.)