There is no device supporting CUDA

Impressed with what I could do on my 8400 GS I just got a system with an 8800GTX, using an Xeon Dual core - running Ubuntu.

I’ve just finished installing the SDK, and when I run deviceQuery I get :

There is no device supporting CUDA.

Device 0: "Device Emulation (CPU)"

  Major revision number:                         -1

  Minor revision number:                         -1

  Total amount of global memory:                 -1 bytes

  Total amount of constant memory:               65536 bytes

  Total amount of shared memory per block:       16384 bytes

  Total number of registers available per block: 8192

  Warp size:                                     32

  Maximum number of threads per block:           512

  Maximum sizes of each dimension of a block:    512 x 512 x 64

  Maximum sizes of each dimension of a grid:     65535 x 65535 x 1

  Maximum memory pitch:                          262144 bytes

  Texture alignment:                             256 bytes

  Clock rate:                                    1350000 kilohertz

I see other people have this problem, and found clues in the nvidia installer log. I see nothing in /var/log/. This is what I get when i run ldd against deviceQuery:

ldd deviceQuery  => /usr/local/cuda/lib/ (0x00002aae1af30000) => /usr/lib/ (0x00002aae1b165000) => /usr/lib/ (0x00002aae1b328000) => /usr/lib/ (0x00002aae1b5ac000) => /usr/lib/ (0x00002aae1b7f1000) => /lib/ (0x00002aae1bafc000) => /lib/ (0x00002aae1bd7d000) => /lib/ (0x00002aae1bf8c000) => /lib/ (0x00002aae1c2e7000) => /lib/ (0x00002aae1c4eb000) => /lib/ (0x00002aae1c707000) => /usr/lib/ (0x00002aae1c910000) => /usr/lib/ (0x00002aae1cb21000)

        /lib64/ (0x00002aae1ad12000) => /usr/lib/ (0x00002aae1ce33000) => /usr/lib/ (0x00002aae1d035000)

Any hints of where to look next?

It appears that I accidentally installed the 32bit nvidia driver instead of the 64bit one. Now deviceQuery returns the correct results.

However, when I re-make any of the projects in the SDK, such as deviceQuery, i get an internal error:

nvopencc INTERNAL ERROR: /usr/local/cuda/open64/lib//gfec died due to signal 11

nvopencc ERROR: core dumped

make: *** [obj/release/deviceQuery.cu_o] Error 255