There is no device supporting CUDA

I have a machine with Red Hat Enterprise Linux 4 installed. The machine has 3 8800 GTX in it. I installed the drivers, toolkit and SDK and compiled all the sample code.

When I try and run something in debug or release (meaning, on the GPU), I get this error.

In case this is informative:

What should I do to fix this?

Specifically which drivers did you install?
Did you start X first?

I installed the ones off the website. The file is called I am guessing that means I installed 100.14.11

X is running.

What is the output of “ls -l /dev/nv*”?

[cudauser@cuda3-linux ~]$ ls -l /dev/nv*

crw------- 1 cudauser root 195, 0 Sep 26 07:39 /dev/nvidia0

crw------- 1 cudauser root 195, 1 Sep 26 07:39 /dev/nvidia1

crw------- 1 cudauser root 195, 2 Sep 26 07:39 /dev/nvidia2

crw------- 1 cudauser root 195, 255 Sep 26 07:39 /dev/nvidiactl

Permissions are ok.
If you try to run deviceQuery, what is the output?
Do you have some old Cuda installation on your system?
Check with ldd that you are pointing to the new runtime.

The install is brand new. No previous versions of CUDA.

Can you elaborate on deviceQuery and ldd?

Is deviceQuery a CUDA function?

Here is the output from ldd in the /usr/local/cuda/lib directory. Not sure if this is what you meant.

Sorry, I “found” deviceQuery. Here is the output from release, emurelease, emudebug:

BUT, if I run it in debug mode:

Problem solved!

Looking in /var/log/nvidia-installer.log, there was something about things failing because “out of vmalloc space”. With this hint, I found a thread…8975&hl=vmalloc

where someone has solved this problem.

You need to edit your grub to make it like the one below. For me, that meant adding the uppermem, vmalloc and pci parts. Now I have three GPUs.

Thanks everyone for your help and quick responses.


I’m running openSUSE 10.3 (AMD64) and GeForce 8800 GT. I managed to compile some examples in the SDK after having performed an installation according to…notes_linux.txt, along with some previously posted instructions (concerning gcc-4.2->4.1 and glut).

When I execute for example matrixMul I get “There is no device supporting CUDA”. Make and execution of deviceQuery yields:

There is one difference in the output compared to the previous post in this thread:

That doesn’t sound to good … but I do not know how to fix it. Can someone help me solve this? See also the attached nvidia-bug-report.log (extension changed to .txt due to upload restrictions).
nvidia_bug_report.txt (121 KB)

I decided to try Fedora 7 instead, and it worked fine. A possible explanation to my suse troubles could be that I did not kill X before installing the nvidia driver.