deviceQuery

Hi all:
When I run the following:

~/NVIDIA_GPU_Computing_SDK/C/bin/linux/release$ ./deviceQuery

I get the following message

CUDA Device Query (Runtime API) version (CUDART static linking)
There is no device supporting CUDA

Test PASSED

I have the CUDA driver. You can see the attached file.

Any comments??

Thanks,
malik
Screenshot.png

Howdy Malik,

I’ve got the same problem - see “install problem”. I don’t get an X server window though because my X server is not nVidia based.

As root do an lsmod and see if the nvidia driver shows up, and also check ls -l /dev/nvi* to make sure the device files have been generated.

If you’ve got all that, then we do have the same problem and it’d be nice to know the solution!

What version of CUDA are you using and where did you install the driver from?

I’d recommend to upgrade driver to the most recent version (190.42 for now)

There is a problem with at least OpenSuSE 11.2, that I seem to be too stupid to fix through configuration files (have tried): whenever the machine is rebooted, udev creates entries /dev/nvidiactl and /dev/nvidia[01] (I have two GTX260). Those are owned by owner root / group video and have permissions crw-rw----, accessible by owner and group only. I have to do a ‘sudo chmod 666 /dev/nvidia*’ to be able to access the cards as a plain user. A device query returns only one emulation device for as long as the permissions are crw-rw---- and two GTX 260 when they are crw-rw-rw-.