deviceQuery sample missing? sample missing, then dosent work!

Hello everyone,
This is my first time working with cuda programming. I installed the SDK and the toolkit (4.1.28) on my linux machine (Ultimate edition linux 3.0). I got started with the Get started Guide. Install went fine, config went fine. So I tried to do the first sample, deviceQuery. I turns out the files are missing. So I decided to download the files manually. I put them in ~/NVIDIA_GPU_Computing_SDK/C just like they are supposed to be. I ran the make file and got this:
ueuser@ueuser ~/NVIDIA_GPU_Computing_SDK/C $ make
Makefile:48: …/…/common/common.mk: No such file or directory
make: *** No rule to make target `…/…/common/common.mk’. Stop.

Anyone know what is going on?
The graphics card is a Galaxy Geforce GT 520 2GB ram.
Screenshot.png

It’s really weired that you say the files were missing. Are you sure you did that right? I have them in cuda4-samples/C/src/deviceQuery.

The error message that you’re getting is standard. I think you should go to the root directory (cuda4-samples on my machine) and simply type ‘make’ to make everything.

Also:

Try this: remove all the object files and the binary associated with deviceQuery, then run “make -n”. That will print exactly what commands would be executed to compile the deviceQuery sample. If you type those commands manually, it’ll compile. That way, you can fiddle around with the Makefile a bit, and get something simple working.

Samples/demos would be easier to read and more educational if the Makefiles were simpler and everything depended only on the main SDK libraries that are being demoed, as opposed to depending on several secondary “sample helper” libraries etc. A demo should be very short and to the point, like “hello world,” so busy people can read it in a short afternoon, without becoming pros at make/config/etc. which many people aren’t experts at.

In that spirit, make sure to check this thread: http://forums.nvidia.com/index.php?showtopic=166151
At the very top, ‘seibert’ posts a link to some sample benchmarks of his. It is tiny, easy to compile, and teaches you the basic stuff:
https://bitbucket.org/seibert/fermi_test/src/
There are 6 sample programs there which you can download and play with. However, I think they are for the Fermi architecture(Geforce 430-GT, 480-GTX etc.)

Sorry, of course your Geforce GT 520 is also Fermi!

I found the samples, for some reason they weren’t put in a samples folder.there is no sample folder. they were put in the src folder. I made device query. but I can’t seem to get the program to run. What command should I use?

Hi ryanvade

I’m also new here and I had the same problem and I had to do the following steps:

cd ~/NVIDIA_GPU_Computing_SDK/C/src/deviceQuery

make

cd ~/NVIDIA_GPU_Computing_SDK/C/bin/linux/release

./deviceQuery

, this worked for me.

Cheers

Fernando

Thank you!! I didn’t think of that! ./ why didn’t I think of that!