Display corruption with driver 510.54, Linux 5.17.0, X11, Gnome 42

Not sure if this is a Gnome/Mutter issue, an Nvidia driver issue, or a problem with my system configuration. Probably the latter. I took a photo of my screen because it was hard to capture what I’m seeing in a screenshot:

Issue appears in GDM and in gnome-shell. GDM looks right on Wayland but gnome-shell hangs (probably unrelated), so I’m trying to use X11 instead. A non-composited DE like openbox looks fine.

Disabling “flipping” in nvidia-settings makes the system more usable. Corruption appears mostly in the bottom 1/4 of the screen with flipping disabled.

I have nomodeset and nvidia-drm.modeset=0 in kernel command line.

Lightly redacted bug report:

nvidia-bug-report.log.gz (443.3 KB)

Thank you for your help.

I’m having exactly the same problem, but with nvidia-drm.modeset=1, so that seems not to be relevant.

Same over here.
Fun fact, I’m also using gentoo linux - maybe it’s somehow gentoo related.
I saw this issue now on three diffrent maschines, two workstations and one notebook. This issue begun after updating to gnome 42. The driver works fine with gnome <42 (either wayland or X11).


setting “Force Composition Pipeline” and “Force Full Composition Pipeline” in xorg.conf made gnome 42 more usable, at least for me. But some glitches are still there.

I think it may be, I don’t use Gnome but I gave a quick shot at reproducing. Comparing ebuilds for x11-wm/mutter-41 and 42, I noticed this was new:
I tried to drop the line, rebuilt mutter, and the issues went away for me (be nice if someone could confirm, I only tested quick this in a passthrough VM and not familiar with Gnome).


Actually, I went ahead and pushed the change. It’ll be in mutter-42.0-r1 (note -r1) – hope it fixes things for people here.


Nice! I thought about something similar, as well. I’ll test this later and give you a response in here.

1 Like

I can confirm that this fixes the issue!


Fixes it for me too, thank you @ionen!

1 Like

Fixes X11 for me too, wonderful! Thanks! …but why? How?

I wouldn’t know exactly, libOpenGL is preferable over libGL where possible (to avoid libGLX dependency) but it does lack some functions and maybe(?) nvidia drivers and/or mutter act differently when it’s used and it happened to trigger some obscure issues.

Is there already an issue opend on our gentoo bugtracker? (didn’t see any)

Because it might be, that this only needs to be disabled when VIDEO_CARDS contains “nvidia” - haven’t any issue with gnome 42 and AMD drivers. (yep, I know that doesn’t belong into this forum)

Not that I know of, but the issue came up a lot on IRC and linked this thread too, which is what prompted me to test (and mutter’s maintainer doesn’t use nvidia hardware as far as I’m aware).

That aside, I don’t think this is worth being conditional at the moment given mutter still depends on X libraries either way and libglvnd[X] will be dragged (along with libGLX). VIDEO_CARDS=nvidia on mutter is also mostly for EGLStream, and someone may want to disable that for other reasons without having it subtly switch GL libraries.

1 Like

Memo to myself, reactivate IRC… :-)

Thanks for the explanation, you’re totally right with the libglvnd[X] thingy. (donno why I missed that)

Anyways, many thanks for the quick fix!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.