dlls not found when debugging


This is probably a very silly question since I’m only pretending to be a windows developer, but:

When I try to debug (F5) my own project generated from the toolkit template, I get the cuda runtime dlls can’t be found/loaded. In a debug build it misses cudart32_30_14.dll.

I realize I could copy the dll to the project directory or add an entry to the system PATH, but those seem like poor solutions. The samples run fine… where in the world are they setting the correct search paths??

This is using VS2008 on 64-bit Win7.

Pointers would be greatly appreciated!


I’m getting the same problem. I’m also running VS 2008 and 64-bit Win7. I built my project using CMake and FindCUDA (the same project worked fine on a WinXP machine running Cuda 2.2.) Unfortunately, I come from a .NET background, so my C++ compiler skills are lacking on errors like these. My running guess is that FindCUDA hasn’t been updated to work properly with Cuda 3.0, but that’s a stab in the dark right now.

The message I’m getting is:

“The program can’t start because cudart32_30_14.dll is missing from your computer. Try reinstalling the program to fix this problem.” The file is right there in c:\cuda\bin. I get the same error on both debug or release builds.

Copying the .dll to the project folder did the trick, but it seems there should be an easier answer.